ACM已知面积求最小周长

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper. 
T\leq 10,n\leq {10}^{9}
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

3
2
7
12
 

Sample Output

6
16
14
解题思路:
题目的大意就是给定一个矩形的面积要我们求出这个矩形的最小周长。
我们知道一个矩形的最大周长是这样产生的,就是当它的一条边等于面积的大小时,另一条边是1.题目中要求长和宽都要是整数,所以我们要求的就是面积的因子的乘机的最小值。
程序代码:
#include <iostream>
using namespace std;
int main()
{
    int T,j;
    int x;
    cin>>T;
    while(T--)
    {
        cin>>x;
        int min=(1+x)*2,t;
        for(int k=2;k*k<=x;k++)
        {
            if(x%k==0)
            {
                j=x/k;
                  t=2*j+2*k;
                if(t<min)
                 min=t;
            }

        }
        cout<<min<<endl;
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/xinxiangqing/p/4693035.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值