poj3258——二分优化

poj3258——二分优化

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8201 Accepted: 3531

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
 
题意:一些石头排成一条线,第一个和最后一个不能去掉,其余的共可以去掉m块,要使去掉后石头间距的最小值最大
思路:和poj3273几乎完全一样,一样的二分,一样的利用两个i,j指针进行贪心判断,不过二分时要注意的是poj3273中mid=(low+high)/2,而这里mid=(low+high)/2+1,因为这里是找最大的,(2+3)/2=2,而不是等于3或2.5,如果这里没有+1,会死循环。
/**
 * start at 16:40
 * end at 17:21
 * time: 41 min
 * problem: poj3258
 *
 */

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>

using namespace std;

typedef long long ll;
const int maxn=1000100;
const ll INF=(1LL<<60);

ll L;
int N,M;
ll pos[maxn];

//int times=1;

bool judge(ll limit)
{
    //cout<<times++<<endl;
    int del_cnt=0;
    for(int i=0,j=1;j<=N+1;j++){ ///用i和j指针控制贪心
        if(pos[j]-pos[i]<limit) del_cnt++;
        else i=j;
    }
    if(del_cnt<=M) return true;
    return false;
}

ll BinSearch(ll low,ll high)
{
    while(low<high){
        ll mid=(low+high)/2+1;///下面是low=mid,所以这里+1,如果下面是high=mid,则不用+1。因为(2+3)/2=2,而不是等于3或2.5,,此处的处理避免死循环
        //cout<<low<<" "<<high<<" "<<mid<<endl;
        if(judge(mid)) low=mid;
        else high=mid-1;
    }
    return low;
}

int main()
{
    while(scanf("%lld%d%d",&L,&N,&M)!=EOF){
        pos[0]=0;
        pos[N+1]=L;
        for(int i=1;i<=N;i++) scanf("%lld",&pos[i]);
        sort(pos,pos+N+1);
        //for(int i=0;i<=N+1;i++) cout<<i<<" "<<pos[i]<<endl;
        ll Min=INF;
        for(int i=1;i<=N+1;i++){
            if(pos[i]-pos[i-1]<Min) Min=pos[i]-pos[i-1];
        }
        //cout<<Min<<endl;
        printf("%lld\n",BinSearch(Min,L));
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/--560/p/4378656.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值