【POJ2886】Who Gets the Most Candies?-线段树+反素数

Time Limit: 5000MS Memory Limit: 131072K
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.
The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.
The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3
Source

POJ Monthly–2006.07.30, Sempr。

题意:n个人,每一个人手上都有一张牌,牌上的数字表示下一个出去的人的相对位置,正数为顺时针,负数为逆时针,第i个出队的人会得到i的约数个糖果,问谁出队的时候得到的糖果最多。

对于最大糖果数和出队的次序可以由反素数判断。对于下一个出对的人在现在队列中的位置可以由相对位置决定。

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <iostream>
#include <algorithm>

using namespace std;

const int Max = 1e6*4;

int a[] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,554400,665280,720720};//反素数表

int sum[] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,216,224,240};//反素数对应的约束的个数。

typedef struct node
{
    char name[11];

    int Op;
}Stu;

int Tr[Max];

Stu s[550000];

void Build(int L,int R,int st)
{
    Tr[st] = (R-L+1);

    if(L == R) return ;

    int mid = (L + R)>>1;

    Build(L,mid,st<<1);

    Build(mid+1,R,st<<1|1);
}

int update(int L,int R,int st,int x)
{
    Tr[st] --;

    if( L == R ) return L;

    int mid = (L + R)>>1;

    if(x<=Tr[st<<1]) return update(L,mid,st<<1,x);

    else return update(mid+1,R,st<<1|1,x-Tr[st<<1]);
}

int main()
{
    int n,k;

    while(~scanf("%d %d",&n,&k))
    {
        for(int i = 1 ;i<=n;i++)
        {
            scanf("%s %d",s[i].name,&s[i].Op);
        }

        int m = 0;

        int p =0 ;

        while(a[p]<=n) p++;

        m = a[p-1];

        int ans = p-1;

        Build(1,n,1);

        int Mod = n;

        int pos;

        while(m--)
        {
            pos = update(1,n,1,k);

            Mod --;

            if(!Mod)
            {
                break;
            }
            //下一个出队的人的位置
            if(s[pos].Op>=0) k = ((k-1+s[pos].Op-1)%Mod+Mod)%Mod+1;

            else k = ((k-1+s[pos].Op)%Mod+Mod)%Mod+1;
        }
        printf("%s %d\n",s[pos].name,sum[ans]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255852.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值