poj 2886 Who Gets the Most Candies?(线段树)

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers  N (0 <  N  ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

Source

POJ Monthly--2006.07.30, Sempr

题意:

n个熊孩子按顺时针排列,每个人手上都有一张牌,牌上有一个数字,从第k个孩子开始出队,出队的熊孩子卡上数字是K,则顺时针第k人是下一个出队的,负数则逆时针,第P个出队的会得到的糖果数是p的因子个数,输出得到最多糖果的人和他的糖果数,如果有多个,则输出最先出队的。
思路: 要求因子个数最多,我们可以先预处理得到反素数求出最多的糖果数和对应出队的序号;
线段树储存区间的大小,单点更新通过插入第几个位置k,求出对应的位置pos,至于每次的k我们可以通过公式求出;
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=500005;
int s[40] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,500001};
int b[40] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,1314521};
char c[N][11];
int a[N];
struct node{
    int l,r,w;
}str[N*3];
void build(int l,int r,int n)
{
    str[n].l=l;
    str[n].r=r;
    if(l==r)
    {
        str[n].w=1;
        return;
    }
    int temp=(l+r)/2;
    build(l,temp,2*n);
    build(temp+1,r,2*n+1);
    str[n].w=str[2*n].w+str[2*n+1].w;
}
int inser(int n,int w)
{
    if(str[n].l==str[n].r)
    {
        str[n].w=0;
        return str[n].l;
    }
    str[n].w--;
    if(w<=str[2*n].w)
        return inser(2*n,w);
    else
        return inser(2*n+1,w-str[2*n].w);
}
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=1;i<=n;i++)
            scanf("%s%d",c[i],&a[i]);
        build(1,n,1);
        int i=0;
        while(s[i]<=n) i++;
        int maxn=b[i-1];
        int p=s[i-1];
        int pos;
        while(p--)
        {
            n--;
            pos=inser(1,k);
            if(!n)
                break;
            if(a[pos]>0)
                k=(k-1+a[pos]-1)%n+1;//涉及模运算令代号从0开始,所以开始要减1,如同数空位线段树一样,k得到的是新树的第几个位置,a[pos]-1是除去本身删除的点; 
            else
                k=((k-1+a[pos])%n+n)%n+1;
        }
        printf("%s %d\n",c[pos],maxn);
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值