UVa 10391 Compound Words

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
 
 
 
 
这道题刚开始直接暴力,遍历每个单词并且合成,然后寻找是否有合成后的单词出现,结果TLE
后来把每个单词拆分,然后看拆分后的两个部分是否存在,AC
思路很重要,盲目暴力准TLE!
 
 
 
 
#include <bits/stdc++.h>
using namespace std;

int main()
{
    vector<string> table;
    string temp;
    while(cin >> temp)
        table.push_back(temp);
    sort(table.begin(), table.end());

    for(int i = 0; i<table.size(); i++)
    {
        for(int j = 1; j<table[i].size()-1; j++)
        {
            string str1 = table[i].substr(0, j);
            string str2 = table[i].substr(j, table[i].size());
            if(binary_search(table.begin(), table.end(), str1) && binary_search(table.begin(), table.end(), str2))
            {
                cout << table[i] << endl;
                break;
            }
        }
    }
    return 0;
}


转载于:https://www.cnblogs.com/kunsoft/p/5312795.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值