ACM: uva 10391 - Compound Words

Compound Words

 

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn

 

题意: 在字典中找出, 复合词, 即一个单词是由字典里面另外的两个词连接而成的.

 

解题思路:

     1. 哈希题.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAXHASH 121021
#define MAX 121021

char str[MAX][30];
int count;
int next[MAX], first[MAX], num;

int elfHash(char *key)
{
 unsigned long h = 0;
 while(*key)
 {
  h = (h << 4) + *key++;
  unsigned long g = h & 0xf0000000L;
  if(g) h ^= g >> 24;
  h &= ~g;
 }
 return (h+MAXHASH) % MAXHASH;
}

void init()
{
 num = 0;
 count = 1;
 memset(first, -1, sizeof(first));
}

void insert(char *ch)
{
 int hash = elfHash(ch);
 next[++num] = first[hash];
 first[hash] = num;
}

bool search(char *ch)
{
 int hash = elfHash(ch);
 for(int i = first[hash]; i != -1; i = next[i])
  if(strcmp(ch, str[i]) == 0 )
   return true;
 return false;
}

int main()
{
// freopen("input.txt", "r", stdin);
 init();
 while(scanf("%s", str[count]) != EOF)
  insert(str[count++]);
 char temp[30];

 for(int i = 1; i <= count; ++i)
 {
  strcpy(temp, str[i]);
  for(char *p = temp+1; *p != '\0'; ++p)
  {
   char ch = *p;
   *p = '\0';
   if( search(temp) )
   {
    *p = ch;
    if( search(p) )
    {
     printf("%s\n", temp);
     break;
    }
   }
   *p = ch;
  }
 }

 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值