c++心得00008- strcmp函数

1.需要的头文件是这个 #include <string.h>

 strcmp函数的原型是 int strcmp(const char*s1, const char*s2).

2.功能:比较字符串s1和s2。这里面只能比较字符串,不能比较数字等其他形式的参数(用整个char去比也可以)

          strcmp(字符串1,字符串2)

      当s1<s2时,返回<0

         当s1=s2时,返回0

         当s1>s2时,返回>0
        ps:两个字符串自左向右逐个字符相比(按ASCII值大小相比较),直到出现不同的字符或遇'\0'为止。
3.例子加我的acm题。
 

1002.    Maya Calendar
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 8902    Accepted Runs: 1948



During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called  Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were  pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called  uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, ... , where the number 0 was the beginning of the world. Thus, the first day was:

  • Haab: 0. pop 0
  • Tzolkin: 1 imix 0

    Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

    Input

    The date in Haab is given in the following format:

    NumberOfTheDay. Month Year

    The first line of the input contains the number of the input dates in the input. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

    Output

    The date in Tzolkin should be in the following format:

    Number NameOfTheDay Year

    The first line of the output contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

     

    Sample Input

    3
    10. zac 0
    0. pop 0
    10. zac 1995
    

    Sample Output

    3
    3 chuen 0
    1 imix 0
    9 cimi 2801
    
#include<iostream>
#include<string>
#include<stdio.h>
using namespace std;
int main()
{
    int n;
    string h[19]={"pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen","yax", "zac", "ceh", "mac", "kankin", "muan", "pax", "koyab", "cumhu","uayet"};
    string t[20]={"imix", "ik", "akbal", "kan", "chicchan", "cimi", "manik", "lamat", "muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau"};
    cin>>n;
    
    int year,day;
    string month;
    for(int i=1;i<=n;i++)
    {
         if(i==1)
         cout<<n<<endl;
         cin>>day;
         getchar();
         cin>>month;
         cin>>year;
         long tt;
         int i;
         for(i=0;i<19;i++)
         {
                if(h[i]==month)break;
         }
         tt=day+365*year+i*20;
       
         cout<<(tt%260)%13+1<<" "<<t[(tt%260)%20]<<" "<<tt/260<<endl;
    }
  
    return 0;
}
两种玛雅历法的转化啦。

转载于:https://www.cnblogs.com/stigmj/archive/2012/05/13/2497931.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值