ZOJ 2476 Total Amount

ZOJ 2476 Total Amount

Time Limit: 2 Sec  Memory Limit: 128 MB

Submit: 13  Solved: 6

[Submit][Status][Web Board]

Description

Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas

 (a group of one or two digits may appear on the left).

Input

The input consists of multiple tests. The first line of each test contains an integer N

 (1 <= N <= 10000) which indicates the number of amounts. The next N lines

 contain N amounts. All amounts and the total amount are between $0.00

 and $20,000,000.00, inclusive. N=0 denotes the end of input.

Output

For each input test, output the total amount.

Sample Input

2

$1,234,567.89

$9,876,543.21

3

$0.01

$0.10

$1.00

0

Sample Output

$11,111,111.10

$1.11

#include <iostream>
#include<cstdio>
#include<cstring>

using namespace std;
char a[30],ch[20];
long long sum,ans;
int i,n,l;
int main()
{
    while(scanf("%d",&n) && n)
    {
       ans=0;
       for(;n>0;n--)
       {
           scanf("%s",ch);
           l=strlen(ch);
           sum=0;
           for(i=1;i<l;i++)
            if(ch[i]>='0' && ch[i]<='9')
                sum=sum*10+ch[i]-'0';
           ans+=sum;
       }
       printf("%c",ch[0]);
       a[1]=char(ans%10+48);
       ans=ans/10;
       a[2]=char(ans%10+48);
       ans=ans/10;
       a[3]='.';
       l=3;
       if (ans==0) {a[4]='0'; l=4;}
        else
        {
            int num=0;
            while(ans>0)
            {
               if (num==3) a[++l]=',',num=0;
               a[++l]=char(ans%10+48);
               ans=ans/10;
               num++;
            }
        }
       for(i=l;i>=1;i--) printf("%c",a[i]);
       printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/stepping/p/5685801.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值