zoj 2476 Total Amount



Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).


Input

The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between $0.00 and $20,000,000.00, inclusive. N=0 denotes the end of input.


Output

For each input test, output the total amount.


Sample Input

2
$1,234,567.89
$9,876,543.21
3
$0.01
$0.10
$1.00
0


Sample Output

$11,111,111.10
$1.11

题意:就是求和

思路:直接模拟求和累加即可

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
#include <cstring>
#include <stack>
#include  <map>
#include <vector>

using namespace std;


char ans[50005];

int main() {
    int t;
    while(cin >> t && t) {
        memset(ans,0,sizeof(ans));
        int cnt = 0;
        while(t--) {
            getchar();
            char gra[105];
            char shu[105];
            memset(gra,0,sizeof(gra));
            memset(shu,0,sizeof(shu));
            cin >> gra;
            int len = strlen(gra);
            int g = 0;
            for(int i = len-1; i > 0; i--) {
                shu[g++] = gra[i];//把输入的数反过来
            }
            int lena = strlen(ans);
            int k = 0;
            int h = max(lena,g);
            for(int i = 0; i<h; i++) {
                if(shu[i] == ','|| ans[i] == ',') {
                    ans[i] = ',';
                    continue;
                }
                if(shu[i] == '.'|| ans[i] == '.') {
                    ans[i] = '.';
                    continue;
                }
                if(ans[i] != 0) {
                    k += ans[i]-'0';
                }
                if(shu[i] != 0) {
                    k += shu[i]-'0';
                }
                if(k >= 10) {
                    ans[i] = k-10+'0';
                    k = 1;//进位
                } else {
                    ans[i] = k+'0';
                    k = 0;//不进位
                }
            }
            if(k == 1) {//如果超出三个的话加上逗号
                if(h-4 >= 0 && (ans[h-4] == ','||ans[h-4]=='.')){
                    ans[h++] = ',';
                }
                ans[h++] = k+'0';
            }
        }
        printf("$");
        cnt = strlen(ans);
        for(int i = cnt-1; i >= 0; i--) {
            printf("%c",ans[i]);
        }
        printf("\n");
    }
    return 0;
}
很无语,简单题,写了很长时间,各种坑,各种无奈,最近状态又有点不好

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值