Codeforces Round #277.5 (Div. 2)C. Given Length and Sum of Digits...(贪心)

传送门

Description

You have a positive integer m and a non-negative integer s. Your task is to find the smallest and the largest of the numbers that have length m and sum of digits s. The required numbers should be non-negative integers written in the decimal base without leading zeroes.

Input

The single line of the input contains a pair of integers ms (1 ≤ m ≤ 100, 0 ≤ s ≤ 900) — the length and the sum of the digits of the required numbers.

Output

In the output print the pair of the required non-negative integer numbers — first the minimum possible number, then — the maximum possible number. If no numbers satisfying conditions required exist, print the pair of numbers "-1 -1" (without the quotes).

Sample Input

2 15

0 0

Sample Output

69 96

-1 -1

思路

题意:

求由1-9组成的长度为m且各位数之和为s的最大数和最小数。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 105;
int a[maxn];

bool OK(int m, int s)
{
    return s >= 0 && s <= m * 9;
}

int main()
{
    int m, s;
    scanf("%d%d", &m, &s);
    if (!OK(m, s) || (m > 1 && s == 0))  printf("-1 -1\n");
    else
    {
        int cnt = 0, sum = s;
        for (int i = 0; i < m; i++)
        {
            for (int j = 0; j < 10; j++)
            {
                if (((i > 0 || j > 0) || (m == 1 && j == 0)) && OK(m - i - 1, sum - j))
                {
                    sum -= j;
                    a[cnt++] = j;
                    break;
                }
            }
        }

        for (int i = 0; i < cnt; i++) printf("%d", a[i]);
        printf(" ");
        cnt = 0, sum = s;
        for (int i = 0; i < m; i++)
        {
            for (int j = 9; j >= 0; j--)
            {
                if (((i > 0 || j > 0) || (m == 1 && j == 0)) && OK(m - i - 1, sum - j))
                {
                    sum -= j;
                    a[cnt++] = j;
                    break;
                }
            }
        }
        for (int i = 0; i < cnt; i++) printf("%d", a[i]);
        puts("\40");
    }
    return 0;
}

  

 

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6748965.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值