Doing Homework again(杭电1789)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6833    Accepted Submission(s): 4070


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
 
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
 
   
0 3 5
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int str[1010];  //用来标记该天是否占用,刚開始都未使用标记0,用过则标记1。 
struct st
{
    int time,fen;
}data[1010]; 
int cmp(st a,st b)  //科目按扣分从高到低排序。假设扣分同样。则科目期限短的考前。 
{
    if(a.fen!=b.fen)
    return a.fen>b.fen;
    else
    return a.time<b.time;
}
int main()
{
    int i,j,T,n;
    scanf("%d",&T);
    while(T--)
    {
        memset(str,0,sizeof(str));
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&data[i].time);
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&data[i].fen);
        }
        sort(data,data+n,cmp);
        int sum=0;
        for(i=0;i<n;i++)   
        {
            j=data[i].time;
            while(j)    //将扣分多的科目优先放到期限的最后一天完毕。

{ if(!str[j]) //假设那天未被占用,占用那天。跳出while循环,再考虑扣分次多的那个科目。 { str[j]=1; break; } j--; // 假设那天已经被占用,考虑前一天是否被占用。 } if(j==0) sum+=data[i].fen; //假设在期限之内的全部天数均已经被占用。则不得不扣分。

} printf("%d\n",sum); } return 0; }




转载于:https://www.cnblogs.com/wzjhoutai/p/6763257.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值