ZOJ 1610 - Count the Colors

Count the Colors

Time Limit: 2 Seconds      Memory Limit: 65536 KB

 

Paintingsome colored segments on a line, some previously painted segments may becovered by some the subsequent ones.

Your task iscounting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <=8000, equal to the number of colored segments.

Each of thefollowing n lines consists of exactly 3 nonnegative integers separated bysingle spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, cindicates the color of the segment.

All the numbersare in the range [0, 8000], and they are all integers.

Input may containseveral data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from thetop, following the count of the segments of this color, they should be printedaccording to the color index.

If some colorcan't be seen, you shouldn't print it.

Print a blank lineafter every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1

 

【题意】

   在一个长度为8000的区间上面对若干子区间染色n次,每次把区间[x1,x2)染成颜色c,后面的染色操作会覆盖掉区间原来的颜色。最后问每种颜色的区间数量各是多少,按颜色升序输出,如果不存在含该颜色的区间就不输出。每组数据后输出一空行。

 

【思路】

   线段树区间更新问题。题意不难理解,但我感觉题目没有说太清楚,这里有两个比较坑的地方。(1)题目中的所有区间都是从0下标开始的,而且x1,x2指的是一个前闭后开区间即[x1,x2),这里是自己对着样例看了好久才弄明白的。我写的线段树都是从1下标开始的,所以有一个下标偏移要注意。(2)题目中第一句话The first line ofeach data set contains exactly one integer n, 1 <= n <= 8000, equal tothe number of colored segments. 很容易让人理解成n是区间的最大长度,其实这是错的。正确理解是:最大长度是固定的8000,只是有n次染色操作而已,即x1,x2和n没关系,即使n很小,x1,x2也是会达到8000的。这里理解不好线段树就会开小,就RE了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn = 8500;

#define node tree[id]
#define lson tree[id*2]
#define rson tree[id*2+1]

int n;
int col[maxn];
int mp[maxn];
struct Tree {
	int left, right, color;
}tree[maxn * 4];

void pushdown(int id) {
	if (node.color != -1 && node.left != node.right) {
		lson.color = rson.color = node.color;
		node.color = -1;
		//-1表示没有颜色,而且单点的color表示该点的颜色,区间的color表示
		//这一区间的颜色全部为color,所以在pushdown之后重新被赋值为-1
	}
}

void build(int id, int le, int ri) {
	node.left = le;
	node.right = ri;
	node.color = -1;
	if (le == ri) {	return; }
	int mid = (le + ri) >> 1;
	build(id * 2, le, mid);
	build(id * 2 + 1, mid + 1, ri);
}

void update(int id, int x, int y, int v) {
	if (node.left >= x && node.right <= y) {
		node.color = v;
		return;
	}
	pushdown(id);
	int mid = (node.left + node.right) >> 1;
	if (x <= mid) update(id * 2, x, y, v);
	if (y > mid) update(id * 2 + 1, x, y, v);
}

//通过查询把颜色数据存入col数组中
void query(int id, int x, int y) {
	if (node.left == node.right) {
		col[node.left] = node.color;
		return;
	}
	pushdown(id);
	int mid = (node.left + node.right) >> 1;
	if (x <= mid) query(id * 2, x, y);
	if (y > mid) query(id * 2 + 1, x, y);
}

int main() {
	int x, y, v;
	while (scanf("%d", &n) == 1) {
		memset(col, -1, sizeof(col));//color是原区间及其对应的颜色,-1表示没有颜色
		memset(mp, 0, sizeof(mp));//mp[color]表示颜色为color的区间数量
		build(1, 1, 8050);
		for (int i = 1; i <= n; i++) {
			scanf("%d%d%d", &x, &y, &v);
			update(1, x + 1, y, v);//下标要稍做变换
		}
		query(1, 1, 8050);

		for (int i = 1; i <= 8050;) {//遍历区间求每种颜色所含区间的数量
			if (col[i] == -1) { i++; continue; }
			int j = i + 1;
			while (col[j] == col[i] && j <= 8050) j++;
			mp[col[i]]++;
			i = j;
		}
		
		for (int i = 0; i < 8050; i++) {
			if (mp[i]) printf("%d %d\n", i, mp[i]);
		}
		printf("\n");
	}
	return 0;
}


转载于:https://www.cnblogs.com/wafish/p/10465487.html

以下是对提供的参考资料的总结,按照要求结构化多个要点分条输出: 4G/5G无线网络优化与网规案例分析: NSA站点下终端掉4G问题:部分用户反馈NSA终端频繁掉4G,主要因终端主动发起SCGfail导致。分析显示,在信号较好的环境下,终端可能因节能、过热保护等原因主动释放连接。解决方案建议终端侧进行分析处理,尝试关闭节电开关等。 RSSI算法识别天馈遮挡:通过计算RSSI平均值及差值识别天馈遮挡,差值大于3dB则认定有遮挡。不同设备分组规则不同,如64T和32T。此方法可有效帮助现场人员识别因环境变化引起的网络问题。 5G 160M组网小区CA不生效:某5G站点开启100M+60M CA功能后,测试发现UE无法正常使用CA功能。问题原因在于CA频点集标识配置错误,修正后测试正常。 5G网络优化与策略: CCE映射方式优化:针对诺基亚站点覆盖农村区域,通过优化CCE资源映射方式(交织、非交织),提升RRC连接建立成功率和无线接通率。非交织方式相比交织方式有显著提升。 5G AAU两扇区组网:与三扇区组网相比,AAU两扇区组网在RSRP、SINR、下载速率和上传速率上表现不同,需根据具体场景选择适合的组网方式。 5G语音解决方案:包括沿用4G语音解决方案、EPS Fallback方案和VoNR方案。不同方案适用于不同的5G组网策略,如NSA和SA,并影响语音连续性和网络覆盖。 4G网络优化与资源利用: 4G室分设备利旧:面对4G网络投资压减与资源需求矛盾,提出利旧多维度调优策略,包括资源整合、统筹调配既有资源,以满足新增需求和提质增效。 宏站RRU设备1托N射灯:针对5G深度覆盖需求,研究使用宏站AAU结合1托N射灯方案,快速便捷地开通5G站点,提升深度覆盖能力。 基站与流程管理: 爱立信LTE基站邻区添加流程:未提供具体内容,但通常涉及邻区规划、参数配置、测试验证等步骤,以确保基站间顺畅切换和覆盖连续性。 网络规划与策略: 新高铁跨海大桥覆盖方案试点:虽未提供详细内容,但可推测涉及高铁跨海大桥区域的4G/5G网络覆盖规划,需考虑信号穿透、移动性管理、网络容量等因素。 总结: 提供的参考资料涵盖了4G/5G无线网络优化、网规案例分析、网络优化策略、资源利用、基站管理等多个方面。 通过具体案例分析,展示了无线网络优化中的常见问题及解决方案,如NSA终端掉4G、RSSI识别天馈遮挡、CA不生效等。 强调了5G网络优化与策略的重要性,包括CCE映射方式优化、5G语音解决方案、AAU扇区组网选择等。 提出了4G网络优化与资源利用的策略,如室分设备利旧、宏站RRU设备1托N射灯等。 基站与流程管理方面,提到了爱立信LTE基站邻区添加流程,但未给出具体细节。 新高铁跨海大桥覆盖方案试点展示了特殊场景下的网络规划需求。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值