Count the Colors (ZOJ-1610)

Count the Colors (ZOJ-1610)

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.

 

Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

 

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

 

Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

 

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.

 

Sample Input



5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

 

 

Sample Output



1 1
2 1
3 1

 

1 1

0 2
1 1

题目翻译:

在一条直线上画一些彩色的线段,一些以前画过的线段可能被后面的线段覆盖。

你的任务是计算你最终能看到的不同颜色的片段。

输入

每个数据集的第一行恰好包含一个整数n, 1 <= n <= 8000,等于彩色段的数量。

下面的n行每一行由3个非负整数组成,用空格隔开:

(x1, x2) c

x1和x2表示线段的左端点和右端点,c表示线段的颜色。

所有的数字都在[0,8000]范围内,它们都是整数。

输入可以包含多个数据集,处理到文件末尾。

输出

输出的每一行都应该包含一个可以从顶部看到的颜色索引,在此颜色的段数之后,应该根据颜色索引打印它们。

如果有些颜色看不到,就不应该打印出来。

在每个数据集之后打印空行。

思路:

用懒人标记,区间修改,按0~8000的顺序输出

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define PI 3.1415926
#define inf 0x3f3f3f3f
const int maxn=100010;
using namespace std;
int Sum[maxn<<2];
int A[maxn<<2];
int num[maxn<<2];
int t;
void PushDown(int rt)
{
    if(Sum[rt]!=-1)
    {
        Sum[rt<<1] = Sum[rt<<1|1]=Sum[rt];
        Sum[rt]=-1;
    }
}

void Update(int x, int y,int k, int l,int r,int rt)
{
    if(l>=x && r<=y)
    {
        Sum[rt]=k;
        return ;
    }
    PushDown(rt);
    int m=(l+r)>>1;
    if(m>=x)
        Update(x,y,k,l,m,rt<<1);
    if(m<y)
        Update(x,y,k,m+1,r,rt<<1|1);
}

void Query(int l,int r,int rt)
{
    if(l==r)
    {
        A[t++]=Sum[rt];
        return;
    }
    PushDown(rt);
    int m=(l+r)>>1;
    Query(l,m,rt<<1);
    Query(m+1,r,rt<<1|1);

}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(Sum,-1,sizeof(Sum));
        int x,y,k;
        while(n--)
        {
            scanf("%d%d%d",&x,&y,&k);
            Update(x+1,y,k,1,8000,1);
        }
        memset(A,-1,sizeof(A));
        t=0;
        Query(1,8000,1);
        memset(num,0,sizeof(num));
        int i,j;
        for(i=0; i<t;)
        {
            if(A[i]==-1)
            {
                i++;
                continue;
            }
            num[A[i]]++;
            for(j=i+1; j<t; j++)
            {
                if(A[j]!=A[i]||A[j]==-1)
                    break;
            }
            i=j;
        }
        for(int i=0; i<=8000; i++)
        {
            if(num[i])
                printf("%d %d\n",i,num[i]);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值