并查集+向量偏移

http://poj.org/problem?id=1703

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31589 Accepted: 9739

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目大意:在这个城市里有两个黑帮团伙,现在给出N个人,问任意两个人他们是否在同一个团伙
输入D x y代表xy不在一个团伙里
输入A x y要输出xy是否在同一团伙或者不确定他们在同一个团伙里

用图解释一下并查集的向量偏移

加入12是敌人,23是敌人,用mark[]标记01,更新如下;

a=1;b=2  ==>  x=1,y=2; ==> f[1]=2;

Mark[1]=(mark[1]+mark[2]+1)%2=1;

a=2,b=3 ==> x=2,y=3; ==> f[2]=3;

Mark[2]=(mark[2]+mark[3]+1)%2=1;

现在找13是什么关系;

递归过程:

x=1;f[x]=2;x!=f[x]; t=f[x]=2  ==<f[x]=finde(f[x])>==> 

x=2;f[x]=3;x!=f[x], t=f[x]=3  ==<f[x]=finde(f[x])>==>

x=3;f[x]=3; return f[x];  <==f[x]=finde(f[x])==

Mark[2]=(mark[2]+mark[t=3])%2=1; return f[x];  <==f[x]=finde(f[x])==

Mark[1]=(mark[1]+mark[t=2])%2=0; return f[x];

更新完;

发现mark[1]==mark[3];就是一类;

 程序:

#include"stdio.h"
#include"string.h"
#include"queue"
#include"stack"
#include"math.h"
#include"iostream"
#define M 100005
#define inf 100000000
#define mod 10007
#define eps 1e-10
using namespace std;
int f[M],mark[M];
int finde(int x)
{
    if(x!=f[x])
    {
        int t=f[x];
        f[x]=finde(f[x]);
        mark[x]=(mark[x]+mark[t])%2;
    }
    return f[x];
}
void make(int a,int b)
{
    int x=finde(a);
    int y=finde(b);
    if(x!=y)
    {
        f[x]=y;
        mark[x]=(mark[a]+mark[b]+1)%2;
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,i;
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            f[i]=i;
        memset(mark,0,sizeof(mark));
        while(m--)
        {
            int a,b;
            char str[3];
            scanf("%s%d%d",str,&a,&b);
            if(str[0]=='D')
            {
                make(a,b);
            }
            else
            {
                int x=finde(a);
                int y=finde(b);
                if(x!=y)
                    printf("Not sure yet.\n");
                else if(mark[a]==mark[b])
                    printf("In the same gang.\n");
                else
                    printf("In different gangs.\n");
            }
        }
    }
    return 0;
}



转载于:https://www.cnblogs.com/mypsq/p/4348175.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值