1074. Reversing Linked List (25)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

用c语言,用数组存链表,地址即为下标,按照地址读一遍链表,然后存在指针数组p中,再按要求输出。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <map>
using namespace std;
struct node
{
    int add,data,next;
}s[100000],*p[100000],*temp = NULL;
int main()
{
    int n,k,address,a,b,c,d = 0;
    scanf("%d%d%d",&address,&n,&k);
    for(int i = 0;i < n;i ++)
    {
        scanf("%d %d %d",&a,&b,&c);
        s[a].add = a;
        s[a].data = b;
        s[a].next = c;
    }
    for(int i = address;i != -1;i = s[i].next)
    {
        p[d ++] = &s[i];
    }
    for(int i = 0;i < d;i += k)
    {
        if(d - i >= k)
        {
            if(temp != NULL)printf("%05d %d %05d\n",temp -> add,temp -> data,p[i + k - 1] -> add);
            for(int j = k - 1;j > 0;j --)
            {
                printf("%05d %d %05d\n",p[i + j] -> add,p[i + j] -> data,p[i + j - 1] -> add);
            }
            temp = p[i];
            if(d - i == k)printf("%05d %d %d\n",p[i] -> add,p[i] -> data,-1);
        }
        else
        {
            if(temp != NULL)printf("%05d %d %05d\n",temp -> add,temp -> data,p[i] -> add);
            for(int j = i;j < d;j ++)
            {
                if(j == d - 1)printf("%05d %d %d\n",p[j] -> add,p[j] -> data,p[j] -> next);
                else printf("%05d %d %0d\n",p[j] -> add,p[j] -> data,p[j] -> next);
            }
        }
    }
}

 

转载于:https://www.cnblogs.com/8023spz/p/8245358.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值