数据结构 PTA 02-线性结构3 Reversing Linked List (25分) C语言实现

2 篇文章 0 订阅

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

解题:

#include<stdio.h>
typedef struct Node{
	int address;
	int data;
	int next;
}Node;
//在dev c++中好像不能定义这么打的数组在本地变量,迫不得已使用全局变量
Node list[100001];
void print(int i);
int main(void){
	//读入链表数据
	int first, num, k;
	scanf("%d %d %d", &first, &num, &k);
	int i;
	int address, data, next;
	for(i=0;i<num;i++){
		scanf("%d %d %d", &address, &data, &next);
		list[address].address = address;
		list[address].data = data;
		list[address].next = next;
	}
	
	//数出链表长度,为后面翻转做准备
	int m = 0;
	int p = first;
	while(p>=0){
		m++;
		p = list[p].next;
	}
	
	//开始逆转
	int newp, oldp, tp, head;
	int cnt, j;
	int link; 
	head = first;
	if(m>1&&k>1)
		//(n/k)为需要逆转的次数
		for(i=0;i<m/k;i++){
			//逆转的核心代码
			newp = head;
			oldp = list[newp].next;
			for(j=1;j<k;j++){
				tp = list[oldp].next;
				list[oldp].next = newp;
				newp = oldp;
				oldp = tp;
			}
			list[head].next = oldp;
			/*下面是为了保存链表的头
			  first保存整个链表的头
			  head保存还未逆转的链表头
			  link保存逆转了的链表尾节点,保证后面的逆转衔接正常
			*/
			if(i==0)
				first = newp;
			else
				list[link].next = newp;
			link = head;
			head = oldp;
		}
	print(first);
} 
//输出函数
void print(int i){
	while(list[i].next>=0){
		printf("%05d %d %05d\n", list[i].address, list[i].data, list[i].next);
		i = list[i].next;
	}
	printf("%05d %d %d\n", list[i].address, list[i].data, list[i].next);
}
  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值