Hdu Graph’s Cycle Component

Graph’s Cycle Component

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1275    Accepted Submission(s): 499


Problem Description
In graph theory, a cycle graph is an undirected graph that consists of a single cycle, or in other words, some number of vertices connected in a closed chain.
Now, you are given a graph where some vertices are connected to be components, can you figure out how many components are there in the graph and how many of those components are cycle graphs.
Two vertices belong to a same component if and only if those two vertices connect each other directly or indirectly.
 

 

Input
The input consists of multiply test cases.
The first line of each test case contains two integer, n (0 < n < 100000), m (0 <= m <= 300000), which are the number of vertices and the number of edges.
The next m lines, each line consists of two integers, u, v, which means there is an edge between u and v.
You can assume that there is no multiply edges and no loops.
The last test case is followed by two zeros, which means the end of input.
 

 

Output
For each test case, output the number of all the components and the number of components which are cycle graphs.
 

 

Sample Input
8 9 0 1 1 3 2 3 0 2 4 5 5 7 6 7 4 6 4 7 2 1 0 1 0 0
 

 

Sample Output
2 1 1 0
 

 

Author
momodi@WHU
 

 

Source
 
//并查集判断连通分量数,连通分块的每个度数为2代表为圈图
#include <iostream>
#include <algorithm>
#include <queue>
#include <cmath>
#define N 100003
using namespace std;
int f[N];
int r[N];
int find_r(int x)
{
   if(f[x]>=0)
   {
     return  f[x]=find_r(f[x]);
   }
   return x;
}
void union_set(int x,int y)
{
    x=find_r(x);
	y=find_r(y);
	if(x==y) return ;
	if(r[x]>r[y])
	   f[y]=x;
	 else 
		 if(r[x]==r[y])  
		 {
	         f[y]=x;
			 r[x]++;
		 }
		 else
			 f[x]=y;

}
int de[N];
int main()
{
	int i,n,m;
	int x,y;
	int r_n,r_m;
   while(scanf("%d%d",&n,&m),n||m)
   {
	   for(i=0;i<n;i++)  //开始这用memset()函数显示超时、、看来、、、
	   {
	      de[i]=r[i]=0;
		  f[i]=-1;
	   }
       for(i=0;i<m;i++)
	   {
		   scanf("%d%d",&x,&y);
	        union_set(x,y);
			de[x]++;de[y]++;
	   }
	   
	   for(i=0;i<n;i++)
		   if(de[i]!=2)
		   {
		       r_m=find_r(i);
			   r[r_m]=-1;
		   }
		   r_n=r_m=0;
         for(i=0;i<n;i++)
		   if(f[i]==-1)
		   {
		       r_n++;
			   if(r[i]!=-1)
				   r_m++;
		   }
		printf("%d %d\n",r_n,r_m);
   }
   return 0;
}

转载于:https://www.cnblogs.com/372465774y/archive/2012/07/05/2578592.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值