[CodeForces] 274E Mirror Room

题意翻译

有一个n*m的格子图,其中有一些是黑色的,另一些为白色。

从某个白色格子的中心点向左上(NW),左下(SW),右上(NE),右下(SE)四个方向中的一个发出一束光线,若光线碰到黑色格子或者墙壁(即边界)会反射。反射情况如图所示:

我们不难发现,光线能穿过的格子总数是可以算出的。假如光线经过了某个格子的中心,则称光线经过了这个格子。求光线经过的格子总数。

由于答案可能很大,请使用long long的C++选手注意:请勿使用%lld,推荐cout或者%I64d

题目描述

Imagine an n×mn×m grid with some blocked cells. The top left cell in the grid has coordinates (1,1)(1,1) and the bottom right cell has coordinates (n,m)(n,m) . There are kk blocked cells in the grid and others are empty. You flash a laser beam from the center of an empty cell (x_{s},y_{s})(xs,ys) in one of the diagonal directions (i.e. north-east, north-west, south-east or south-west). If the beam hits a blocked cell or the border of the grid it will reflect. The behavior of the beam reflection in different situations is depicted in the figure below.

After a while the beam enters an infinite cycle. Count the number of empty cells that the beam goes through at least once. We consider that the beam goes through cell if it goes through its center.

输入输出格式

输入格式:

 

The first line of the input contains three integers nn , mm and k(1<=n,m<=105,0<=k<=105) . Each of the next kk lines contains two integers(1<=xi<=n,1<=yi<=m) indicating the position of the ii -th blocked cell.

The last line contains(1<=xs<=n,1<=ys<=m) and the flash direction which is equal to "NE", "NW", "SE" or "SW". These strings denote directions (-1,1)(1,1) , (-1,-1)(1,1) , (1,1)(1,1) , (1,-1)(1,1) .

It's guaranteed that no two blocked cells have the same coordinates.

 

输出格式:

 

In the only line of the output print the number of empty cells that the beam goes through at least once.

Please, do not write the %lld specifier to read or write 64-bit integers in С++. It is preferred to use the cin, cout streams or the %I64d specifier.

 

输入输出样例

输入样例#1: 
3 3 0
1 2 SW
输出样例#1: 

6

输入样例#2: 

7 5 3

3 3 4

3 5 3

2 1 SE

输出样例#2: 

14

题目分析

恶心啊。

根据惯例我们先列一下需要考虑的问题:
1.四种方块的反射状态

2.在一定时间后光线会重复循环,此时终止

3.数据范围带来的不能用邻接矩阵存图的麻烦

4.坐标从0开始很不好处理

写吧,细节解决方案看代码

Code

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;

const int MAXN = 1e5 + 10;
const int INF = 0x3f3f3f3f;

int n,m,k;
int sx,sy,sd;
vector<int>    block[MAXN];
string S;
bool flag;

void add(int x,int y) {
    block[x].push_back(y);
    return;
}

void scan() {
    scanf("%d%d",&n,&m,&k);
    scanf("%d%d%s",&sx,&sy,&S);
    if(S == "NW") sd = 1;
    else if(S == "NE") sd = 2;
    else if(S == "SW") sd = 3;
    else if(S == "SE") sd = 4;
    int x,y;
    for(int i = 1;i <= k;i++) {
        scanf("%d%d",&x,&y);
        add(x,y);
    }
    for(int i = 1;i <= n;i++) add(i,0),add(i,m + 1);
    for(int j = 1;j <= n;j++) add(0,j),add(n + 1,j);
    add(0,0);add(n + 1,m + 1);
    return;
}

void dir_judge(int x,int y,int &d) {
    if(d == 1) {
        if(!getblock(x-1,y-1)) return;
        else {
            int opt = getblock(x,y-1) - getblock(x-1,y);
            if(opt == 0) d = 4;
            else if(opt == 1) d = 2;
            else if(opt == -1) d = 3;
        }
    } else if(d == 2) {
        if(!getblock(x-1,y+1)) return;
        else {
            int opt = getblock(x-1,y) - getblock(x,y+1);
            if(opt == 0) d = 3;
            else if(opt == 1) d = 4;
            else if(opt == -1) d = 1;
        }
    } else if(d == 3) {
        if(!getblock(x+1,y-1)) return;
        else {
            int opt = getblock(x,y-1) - getblock(x+1,y);
            if(opt == 0) d = 2;
            else if(opt == 1) d = 4;
            else if(opt == -1) d = 1;
        }
    } else if(d == 4) {
        if(!getblock(x+1,y+1)) return;
        else {
            int opt = getblock(x-1,y) - getblock(x,y-1);
            if(opt == 0) d = 1;
            else if(opt == 1) d = 2;
            else if(opt == -1) d = 3;
        }
    }
}
/*
NW 1    NE 2

SW 3    SE 4
*/

void start() {
    int x = sx,y = sy,d = sd;
    while(!flag) {
        dir_judge(x,y,d);
    }
}

main() {
    scan();
    start();
}

 

 

 

转载于:https://www.cnblogs.com/floatiy/p/9459921.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值