POJ 3735 Training little cats<矩阵快速幂/稀疏矩阵的优化>

Training little cats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13488 Accepted: 3335

Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them. 

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have. 

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

Source

 

/*
题意:多组输入n,m,k。(m≤1,000,000,000, n≤100, k≤100),n表示猫的数量,m代表重复的次数,k表示k次操作。
操作种类:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
解题过程:
   原本以为是一道简单的模拟题,但是m非常的大,会TLE。看了题解,用的是快速幂,第一次写快速幂,做下总结。
 http://www.hankcs.com/program/algorithm/poj-3735-training-little-cats-time.html
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long  LL;
const int maxn=100+5;
struct node
{
    LL a[maxn][maxn];
};
LL n,m,k;
char s[5];
LL x,y;
node multiplay(node a,node b)
{
    node c;
    memset(c.a, 0, sizeof(c.a));
    for(int i=1;i<=n+1;i++)
        for(int j=1;j<=n+1;j++)
        {
            if(a.a[i][j])
            {
                for(int k=1;k<=n+1;k++)
                    c.a[i][k]+=a.a[i][j]*b.a[j][k];
            }
        }
    return c;
}
node M(node a,LL x)
{
    node c;
    memset(c.a, 0, sizeof(c.a));
    for(int i=1;i<=n+1;i++)
        c.a[i][i]=1;
    while(x)
    {
        if(x&1)
            c=multiplay(c, a);
        a=multiplay(a, a);
        x>>=1;
    }
    return c;
}
int main ()
{
    while(~scanf("%lld%lld%lld",&n,&m,&k))
    {
        if(n==0&&m==0&&k==0)    break;
        node A;
        memset(A.a, 0, sizeof(A.a));
        for(int i=1;i<=n+1;i++)
            A.a[i][i]=1;
        for(int i=1;i<=k;i++)
        {
            scanf("%s",s);
            if(s[0]=='g')
            {
                scanf("%lld",&x);
                A.a[x][n+1]+=1;
            }
            else if(s[0]=='e')
            {
                scanf("%lld",&x);
                memset(A.a[x], 0, sizeof(A.a[x]));
            }
            else
            {
                scanf("%lld%lld",&x,&y);
                for(int i=1;i<=n+1;i++)
                    swap(A.a[x][i], A.a[y][i]);
            }
        }
        A=M(A,m);
        node ans;
        memset(ans.a, 0, sizeof(ans.a));
        ans.a[n+1][1]=1;
        ans=multiplay(A, ans);
        for(int i=1;i<=n;i++)
        {
            if(i==1)
                printf("%lld",ans.a[i][1]);
            else
                printf("% lld",ans.a[i][1]);
        }
        printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/pealicx/p/6543651.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值