POJ 3735 Training little cats(矩阵快速幂)

Training little cats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:14975 Accepted: 3708

Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

题解:
设n=3
第一个人加一:
    1 0 0 1    a1   a1+1
    0 1 0 0 *  a2 = a2
    0 0 1 0    a3   a3
    0 0 0 1    a4   a4
第一个人吃光:
    0 0 0 0    a1   0
    0 1 0 0 *  a2 = a2
    0 0 1 0    a3   a3
    0 0 0 1    a4   a4
第一个人与第二个人交换:
    0 1 0 0    a1   a2
    1 0 0 0 *  a2 = a1
    0 0 1 0    a3   a3
    0 0 0 1    a4   a4
由于m很大但是每次m循环都是相同操作,因此可以通过
矩阵快速幂快速求解。
代码:

#include<cstdio>
using namespace std;
#define ll long long
ll n,m,k;
struct node
{
    ll t[102][102];
} a,b;
node cheng(node x,node y)
{
    node tmp;
    for(int i=1;i<=n+1;i++)
        for(int j=1;j<=n+1;j++)
        tmp.t[i][j]=0;
    for(int i=1; i<=n+1; i++)
    {
        for(int k=1;k<=n+1;k++)
        {
            if(x.t[i][k])//关于稀疏矩阵的剪枝。
            {
                for(int j=1;j<=n+1;j++)
                    tmp.t[i][j]+=x.t[i][k]*y.t[k][j];
            }
        }
    }
    return tmp;
}
int main()
{
    while(~scanf("%lld%lld%lld",&n,&m,&k))
    {
        if(!(n+m+k))break;
        for(int i=1;i<=n+1;i++)
            for(int j=1;j<=n+1;j++)
            a.t[i][j]=i==j;
        for(int i=1; i<=k; i++)
        {
            for(int i=1; i<=n+1; i++)
                for(int j=1; j<=n+1; j++)
                {
                    if(i==j)b.t[i][j]=1;
                    else b.t[i][j]=0;
                }
            char t[2];
            ll x,y;scanf("%s",&t);
            if(t[0]=='g')
            {
                scanf("%lld",&x);
                b.t[x][n+1]=1;
            }
            else if(t[0]=='e')
            {
                scanf("%lld",&x);
                b.t[x][x]=0;
            }
            else
            {
                scanf("%lld%lld",&x,&y);
                b.t[x][x]=0;
                b.t[x][y]=1;
                b.t[y][y]=0;
                b.t[y][x]=1;
            }
            a=cheng(b,a);
        }
        for(int i=1;i<=n+1;i++)
            for(int j=1;j<=n+1;j++)
            b.t[i][j]=i==j;
        while(m)
        {
            if(m&1)b=cheng(a,b);
            a=cheng(a,a);
            m=m/2;
        }
        for(int i=1;i<=n;i++)
        {
            printf("%lld",b.t[i][n+1]);
            if(i!=n)printf(" ");
            else printf("\n");
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值