【SGU 102】Coprimes

102. Coprimes

time limit per test: 0.5 sec.
memory limit per test: 4096 KB

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

Input

Input file contains integer N.

Output

Write answer in output file.

Sample Input

9

Sample Output

6

   题目让求小于N且与N互质的数的个数。因为看范围貌似暴力就可以,所以我就写了欧拉函数(= =!)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
using namespace std;

int n;

int phi(int x){
	int ans=x;
	for(int i=2;i<(int)sqrt(x*1.0)+1;i++)
		if((x%i==0)){
			ans=ans/i*(i-1);
			while((x%i==0)) x/=i;
		}
	if(x>1) ans=ans/x*(x-1);
	return ans;
}

int main(){
	scanf("%d",&n);
	printf("%d\n",phi(n));
	return 0;
}

转载于:https://www.cnblogs.com/Delostik/archive/2011/08/16/2140467.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值