Coprimes 欧拉函数问题

 

102. Coprimes

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

 

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

 

Input

Input file contains integer N.

 

Output

Write answer in output file.

 

Sample Input

9

 

Sample Output

6

 

因为数据量比较小,所以gcd暴力也是可以过的

当然用欧拉函数更是可以

#include <iostream>
using namespace std ;
const int Maxn = 1e4 + 10 ;

int a[Maxn] ;

void init(){
    a[1] = 1 ;
    for (int i = 2; i < Maxn; i++){
        a[i] = i ;
    }
    for (int i = 2; i < Maxn; i++){
        if (a[i] == i){
            for (int j = i; j < Maxn; j += i){
                a[j] = a[j] / i * (i - 1) ;
            }
        }
    }
}

int main (){
    int n ;
    init() ;
    cin >> n ;
    cout << a[n] ;
    return 0 ;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值