hdoj--5532--Almost Sorted Array(正反LIS)

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1459    Accepted Submission(s): 413


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,an, is it almost sorted?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000.
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
 
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
 
  
YES YES NO
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5609  5608  5607  5605  5604 

给你一个数列,找到一个非递减数列,正反两次LIS就行,好久不用upper_bound写了不对,
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int a[100100],b[100100],s[100100];
int Find(int l,int r,int val)
{
	int mid;
	while(l<=r)
	{
		mid=(l+r)>>1;
		if(s[mid]>val)
		r=mid-1;
		else
		l=mid+1;
	}
	return l;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(s,0,sizeof(s));
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		for(int i=0;i<n;i++)
		b[n-1-i]=a[i];
		int len=1;
		s[0]=-1;
		for(int i=0;i<n;i++)
		{
			if(a[i]>=s[len-1])
			s[len++]=a[i];
			else
			{
				s[len]=10000000;
//				int q=lower_bound(s,s+len,a[i])-s;
				int q=Find(0,len,a[i]);
				if(q==len)
				len++;
				s[q]=a[i];
			}
		}
		if(len-1>=n-1)
		{
			printf("YES\n");
			continue;
		}
		else
		{
			int len=1;
			memset(s,0,sizeof(s));
			s[0]=-1;
			for(int i=0;i<n;i++)
			{
				if(b[i]>s[len-1])
				s[len++]=b[i];
				else
				{
					s[len]=10000000;
					int q=Find(0,len,b[i]);
					if(q==len)
					len++;
					s[q]=b[i];
				}
			}
			if(len-1>=n-1)
			printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}


转载于:https://www.cnblogs.com/playboy307/p/5273519.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值