HDOJ 5532-Almost Sorted Array【模拟】



Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1443    Accepted Submission(s): 410


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array   a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer   T  indicating the total number of test cases. Each test case starts with an integer   n  in one line, then one line with   n  integers   a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with   n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 

Source
 

解题思路

       题目大意就是给出一段数字,让你找出如果将这个数组中的一个数抽出,该数组还是不是一个递增或递减的数组。

       可以判断数组d递增递减两个方面,一次遍历这个数组看看是不是能找到两条沟或两条以上,但是同时还要判断这条沟只能是由一个数字构成的4 5 6 1 2 7 8 9这样的由两个数字组成的沟输出就是NO。

#include<stdio.h>
#define INF 0x3f3f3f3f
int map[100005];
bool F1(int x)
{
	int sum=0;
	map[0]=-INF,map[x+1]=INF;
	for(int i=2;i<=x;i++)
	{
		if(map[i]<map[i-1])
		{
			if(sum==1)
			{
				return false;
			}
			sum++;
			if(map[i+1]>=map[i-1]||map[i]>=map[i-2])
			continue;
			else
			return false;
		}
	}
	return true;
}
bool F2(int x)
{
	int sum=0;
	map[0]=INF,map[x+1]=-INF;
	for(int i=2;i<=x;i++)
	{
		if(map[i]>map[i-1])
		{
			if(sum==1)
			return false;
			sum++;
			if(map[i+1]<=map[i-1]||map[i]<=map[i-2])
			continue;
			else
			return false;
		}
	}
	return true;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&map[i]);
		}
		if(F1(n)||F2(n))
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值