"巴卡斯杯" 中国大学生程序设计竞赛 - 女生专场 C - Luck Competition

Participants of the Luck Competition choose a non-negative integer no more than 100 in their mind. After choosing their number, let KK be the average of all numbers, and MM be the result of K×23K×23. Then the lucky person is the one who choose the highest number no more than MM. If there are several such people, the lucky person is chosen randomly. 

If you are given a chance to know how many people are participating the competition and what their numbers are, calculate the highest number with the highest probability to win assuming that you're joining the competition. 

Input

There are several test cases and the first line contains the number of test cases T(T≤10)T(T≤10). 

Each test case begins with an integer N(1<N≤100)N(1<N≤100), denoting the number of participants. And next line contains N−1N−1 numbers representing the numbers chosen by other participants. 
 

Output

For each test case, output an integer which you have chosen and the probability of winning (round to two digits after the decimal point), seperated by space. 
 

Sample Input

3
4
1 2 3
4
1 1 2
4
20 30 40

Sample Output

1 0.50
0 1.00
18 1.00
#include<iostream>
using namespace std;
int a[1000]; 
int main()
{
	int n,m,j,k,i,T;
	cin>>T;
	while (T--)
	{
		int sum=0;
		scanf("%d",&n);
		for (i=0;i<n-1;i++)
		{
			cin>>a[i];
			sum+=a[i];
		}
			
		int SUM=1;
		int ans = (double)2.0*sum/(3.0*n-2.0);
		for (i=0;i<n-1;i++)
		{
			if (a[i]==ans)
			SUM++;
		}
		double ANS = 1.0/double(SUM);
		printf("%d %.2lf\n",ans,ANS);
	}
	
	return 0;
 } 

 

转载于:https://www.cnblogs.com/Romantic-Chopin/p/10253039.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值