POJ1694 An Old Stone Game

POJ1694 An Old Stone Game
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 2579Accepted: 1137

Description

There is an old stone game, played on an arbitrary general tree T. The goal is to put one stone on the root of T observing the following rules: 
  1. At the beginning of the game, the player picks K stones and puts them all in one bucket. 
  2. At each step of the game, the player can pick one stone from the bucket and put it on any empty leaf. 
  3. When all of the r immediate children of a node p each has one stone, the player may remove all of these r stones, and put one of the stones on p. The other r - 1 stones are put back into the bucket, and can be used in the later steps of the game.

The player wins the game if by following the above rules, he succeeds to put one stone on the root of the tree. 
You are to write a program to determine the least number of stones to be picked at the beginning of the game (K), so that the player can win the game on the given input tree. 

Input

The input describes several trees. The first line of this file is M, the number of trees (1 <= M <= 10). Description of these M trees comes next in the file. Each tree has N < 200 nodes, labeled 1, 2, ... N, and each node can have any possible number of children. Root has label 1. Description of each tree starts with N in a separate line. The following N lines describe the children of all nodes in order of their labels. Each line starts with a number p (1 <= p <= N, the label of one of the nodes), r the number of the immediate children of p, and then the labels of these r children.

Output

One line for each input tree showing the minimum number of stones to be picked in step 1 above, in order to win the game on that input tree.

Sample Input

2
7
1 2 2 3
2 2 5 4
3 2 6 7
4 0
5 0
6 0
7 0
12
1 3 2 3 4
2 0
3 2 5 6
4 3 7 8 9
5 3 10 11 12
6 0
7 0
8 0
9 0
10 0
11 0
12 0

Sample Output

3
4

Source

**********************************************************************
题目大意:在一棵树上面放石头,必须先放满一个节点的儿子才能才这个节点上放石头,当该节点的儿子都放满了,就可以把这些石头放回篮子,然后把一个石头放在这个节点上。问,要放到根节点最少需要多少个石头。
解题思路:第一次看到这道题目是在一次水水的比赛中,当时纠结了半天也没做出来。现在才想得通是树形dp。
要在一个节点上放石头,所需的最少的石头数,是跟他儿子有直接的关系。
首先,如果这个节点是叶子节点,那么dp[s]=1;
如果这个节点不是叶子节点,那么就需要模拟一下:首先取出它儿子中dp[t]最大的那个点,那么dp[s]的起始点就是dp[t],然后模拟篮子中还剩几个石头。把儿子都模拟出来就好了。
#include <stdio.h>
#include <string.h>
#include <vector>
#include <queue>
#define N 205
using namespace std;

vector<int>gra[N];
int dp[N],n;

void dfs(int s)
{
    priority_queue<int>que;
    for(int i=0;i<gra[s].size();i++)
    {
        int t=gra[s][i];
        dfs(t);
        que.push(dp[t]);
    }
    if(gra[s].size()==0)
    {
        dp[s]=1;
        return ;
    }
    int sum=que.top(),temp=sum-1;
    que.pop();
    while(que.empty()==0)
    {
        int t=que.top();
        que.pop();
        if(temp>=t)
            temp=temp-1;
        else
            sum+=t-temp,temp=t-1;
    }
    dp[s]=sum;
}

void re(void)
{
    scanf("%d",&n);
    for(int i=0;i<=n;i++)
        gra[i].clear();
    for(int i=1;i<=n;i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        for(int j=1;j<=b;j++)
        {
            int c;
            scanf("%d",&c);
            gra[a].push_back(c);
        }
    }
}

void run(void)
{
    dfs(1);
    printf("%d\n",dp[1]);
}

int main()
{
    int ncase;
    scanf("%d",&ncase);
    while(ncase--)
    {
        re();
        run();
    }
}

  

转载于:https://www.cnblogs.com/Fatedayt/archive/2011/09/29/2195539.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【优质项目推荐】 1、项目代码均经过严格本地测试,运行OK,确保功能稳定后才上传平台。可放心下载并立即投入使用,若遇到任何使用问题,随时欢迎私信反馈与沟通,博主会第一时间回复。 2、项目适用于计算机相关专业(如计科、信息安全、数据科学、人工智能、通信、物联网、自动化、电子信息等)的在校学生、专业教师,或企业员工,小白入门等都适用。 3、该项目不仅具有很高的学习借鉴价值,对于初学者来说,也是入门进阶的绝佳选择;当然也可以直接用于 毕设、课设、期末大作业或项目初期立项演示等。 3、开放创新:如果您有一定基础,且热爱探索钻研,可以在此代码基础上二次开发,进行修改、扩展,创造出属于自己的独特应用。 欢迎下载使用优质资源!欢迎借鉴使用,并欢迎学习交流,共同探索编程的无穷魅力! 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值