九度OJ 1093:WERTYU (翻译)

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:1563

解决:609

题目描述:

    A common typing error is to place the hands on the keyboard one row to the right of the correct position. So "Q" is typed as "W" and "J" is typed as "K" and so on. You are to decode a message typed in this manner.

输入:

    Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

输出:

    You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.

样例输入:
O S, GOMR YPFSU/
样例输出:
I AM FINE TODAY.
来源:
2006年上海交通大学计算机研究生机试真题

思路:

翻译题,注意细节错误。


代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
 
char keyboard[]={'`','1','2','3','4','5','6','7','8','9','0','-','=','Q','W','E','R','T','Y','U',
'I','O','P','[',']','\\','A','S','D','F','G','H','J','K','L',';','\'','Z','X','C','V','B','N','M',',','.','/'};
 
int main()
{
    char string[1000];
    int i,j;
 
    while(gets(string))
    {
        for(i = 0;i < strlen(string);i++){
            if(string[i] == ' '){
                printf(" ");
            }
            else{
                for(j = 0;j < strlen(keyboard);j++){
                    if(string[i] == keyboard[j]){
                        printf("%c",keyboard[j-1]);
                        break;
                    }
                }
            }
        }
        printf("\n");
    }
    return 0;
}
/**************************************************************
    Problem: 1093
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


转载于:https://www.cnblogs.com/liangrx06/p/5083939.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值