Aeroplane chess(HDU 4405)

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2060    Accepted Submission(s): 1346


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

 

Sample Output
1.1667 2.3441
 

 

Source
 

 

Recommend
zhoujiaqi2010
 

 求期望,逆推。

开始用的递归,结果疯狂爆栈。。。最后改了递推式

#include <cstdio>
#include <iostream>
#include <sstream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define ll long long
#define _cle(m, a) memset(m, (a), sizeof(m))
#define repu(i, a, b) for(int i = a; i < b; i++)
#define MAXN 100050
#define eps 1e-5
bool vis[MAXN];
int flight[MAXN];
int m, n;
double d[MAXN];
int main()
{
    while(~scanf("%d%d", &n, &m) && (n + m))
    {
        _cle(flight, -1);
        _cle(d, 0.0);
        int x, y;
        for(int i = 0; i < m; i++) {
            scanf("%d%d", &x, &y);
            flight[x] = y;
        }
        int dt;
        for(int i = n - 1; i >= 0; i--)
            for(int j = 1; j <= 6; j++) {
              dt = i + j;
              while(flight[dt] > 0) dt = flight[dt];
              d[i] += (d[dt] + 1.0) / 6.0;
            }
        printf("%.4lf\n", d[0]);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/sunus/p/4415797.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值