HDU 3988 Harry Potter and the Hide Story(数论-整数和素数)

Harry Potter and the Hide Story



Problem Description
iSea is tired of writing the story of Harry Potter, so, lucky you, solving the following problem is enough.

 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case contains two integers, N and K. 

Technical Specification

1. 1 <= T <= 500
2. 1 <= K <= 1 000 000 000 000 00
3. 1 <= N <= 1 000 000 000 000 000 000
 

Output
For each test case, output the case number first, then the answer, if the answer is bigger than 9 223 372 036 854 775 807, output “inf” (without quote).
 

Sample Input
 
  
2 2 2 10 10
 

Sample Output
 
  
Case 1: 1 Case 2: 2
 

Author
iSea@WHU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3987  3986  3983  3984  3985 
 

题目大意:

给定 n和k , 求 n! % k^i 等于0时,i 的最大取值是多少?


解题思路:

将 k分解质因素,n也根据k的质因素求出关系限制i,最后算出最大的i即可。


解题代码:

#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <cstring>
using namespace std;

typedef unsigned long long ll;
ll n,k;

const int maxn=10000010;
bool isPrime[maxn];
vector <ll> v;
ll tol;

void get_prime(){
    tol=0;
    memset(isPrime,true,sizeof(isPrime));
    for(ll i=2;i<maxn;i++){
        if(isPrime[i]){
            tol++;
            v.push_back(i);
        }
        for(ll j=0;j<tol && i*v[j]<maxn;j++){
            isPrime[i*v[j]]=false;
            if(i%v[j]==0) break;
        }
    }
    //for(ll i=v.size()-1;i>=v.size()-100;i--) cout<<v[i]<<endl;
}

map <ll,ll> getPrime(ll x){
    map <ll,ll> mp;
    for(ll i=0;i<tol && x>=v[i];i++){
        while(x>0 && x%v[i]==0){
            x/=v[i];
            mp[v[i]]++;
        }
    }
    if(x>1) mp[x]++;
    return mp;
}

void solve(){
    if(k==1){
        printf("inf\n");
        return;
    }
    map <ll,ll> mp=getPrime(k);
    ll ans=1e19;
    for(map <ll,ll>::iterator it=mp.begin();it!=mp.end();it++){
        ll tmp=n,sum=0;
        while(tmp>0){
            sum+=tmp/(it->first);
            tmp/=(it->first);
        }
        if(sum/(it->second)<ans) ans=sum/(it->second);
    }
    cout<<ans<<endl;
}

int main(){
    get_prime();
    int t;
    scanf("%d",&t);
    for(int i=0;i<t;i++){
        cin>>n>>k;
        printf("Case %d: ",i+1);
        solve();
    }
    return 0;
}


转载于:https://www.cnblogs.com/toyking/p/3893157.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值