HDU 3988 Harry Potter and the Hide Story(数论)(素数筛法)

Harry Potter and the Hide Story

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2734    Accepted Submission(s): 688


Problem Description
iSea is tired of writing the story of Harry Potter, so, lucky you, solving the following problem is enough.

 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case contains two integers, N and K.  

Technical Specification

1. 1 <= T <= 500
2. 1 <= K <= 1 000 000 000 000 00
3. 1 <= N <= 1 000 000 000 000 000 000
 
Output
For each test case, output the case number first, then the answer, if the answer is bigger than 9 223 372 036 854 775 807, output “inf” (without quote).
 

Sample Input
  
  
2 2 2 10 10
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 

   肯定要求因子数,然后求指数和。分解    k   的因子,对于每个因子,看其指数为  c,与   n!  里面相同的因子指数为  s,求max(s-c)。

这个数论题目理解还不是很透彻啊,多刷题,多理解

注意,这的const int N = 10000005;如果多以为就爆内存,少一位就wa哭大笑

#include<iostream>//HDU 3988
#include<cstdio>
#include<algorithm>
using namespace std;
const int N = 10000005;
int prime[N],flag[N],num=0;
void Init()//素数打表
{
    for(int i=2;i<=N;i++)
    {
        if(flag[i])
            continue;
        prime[num++]=i;
        for(int j=2;i*j<=N;j++)
            flag[i*j]=1;
    }
}
long long get(long long n,long long p)
{
    long long ret=0;
    while(n)
    {
        n/=p;
        ret+=n;
    }
    return ret;
}
int main()
{
    int t,ans=0;
    cin>>t;
    Init();
    while(t--)
    {
        long long n,k;
        scanf("%lld%lld",&n,&k);
        if(k==1)//k=1时,无穷大,so
        {
            printf("Case %d: inf\n",++ans);
            continue;
        }
        long long maxn=-1;
        for(int i=0;i<num&&prime[i]<=k;i++)
        {
            if(k%prime[i]==0)
            {
                int len=0;
                while(k%prime[i]==0)
                {
                    len++;
                    k/=prime[i];
                }
                long long tmp=get(n,prime[i])/len;
                if(maxn==-1)
                    maxn=tmp;
                else
                    maxn=min(maxn,tmp);
            }
        }
        if(k>1)
        {
            long long tmp=get(n,k);
            if(maxn==-1)
                maxn=tmp;
            else
                maxn=min(maxn,tmp);
        }
        printf("Case %d: %lld\n",++ans,maxn);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值