【POJ 2482】Stars in Your Window(扫描线+线段树)

Stars in Your Window
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11741 Accepted: 3195

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

Source

POJ Contest,Author:kinfkong@ZSU

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

【题解】【扫描线+线段树+离散化】
【这道题重在转化思想,将求小窗的位置转化为求矩形面积并】
【把记录每颗星星转变为记录把当前星星放在左上角的小窗的上下界、横坐标以及星星亮度(即扫描线中记录矩形的方式)。离散化纵坐标,按横坐标排序,然后用线段树维护】
<span style="font-size:18px;"><strong>#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
struct chart{
	ll l,r,x,val;
}a[20020];
ll maxn[100010],delta[100010],hy[20010],ans,xx,yy;
int num[20010],cnt,tot,ly[20010],tp;
int n;
int tmp(int a,int b)
{
	return hy[a]<hy[b];
}
int cmp(chart a,chart b)
{
	return (a.x<b.x||a.x==b.x&&a.val>b.val);//刚开始只写了a.x<b.x 
}
inline void updata(int now)
{
	maxn[now]=max(maxn[(now<<1)],maxn[(now<<1)|1]);
}
inline void pushdown(int now)
{
	if(delta[now])
	 {
	 	maxn[(now<<1)]+=delta[now]; maxn[(now<<1)|1]+=delta[now];
	 	delta[(now<<1)]+=delta[now]; delta[(now<<1)|1]+=delta[now];
	 	delta[now]=0;
	 }
}
void change(int now,int l,int r,int al,int ar,int v)
{
	if(al<=l&&r<=ar)
	 {
	 	maxn[now]+=v;
	 	delta[now]+=v;
	 	return;
	 }
	pushdown(now);
	int mid=(l+r)>>1;
	if(al<=mid) change((now<<1),l,mid,al,ar,v);
	if(ar>mid) change((now<<1)|1,mid+1,r,al,ar,v);
	updata(now);
}
ll ask(int now,int l,int r,int al,int ar)
{
	if(al<=l&&r<=ar) return maxn[now];
	int mid=(l+r)>>1;
	ll ans=0;
    pushdown(now);
    if(al<=mid) ans=max(ans,ask((now<<1),l,mid,al,ar));
    if(ar>mid)  ans=max(ans,ask((now<<1)|1,mid+1,r,al,ar));
    return ans;
}
int main()
{
	freopen("stars.in","r",stdin);
	freopen("stars.out","w",stdout);
	int i,j;
	while((scanf("%d%lld%lld",&n,&xx,&yy)==3))
	 {
	 	ll x,y,v; tot=cnt=tp=ans=0;
	 	memset(maxn,0,sizeof(maxn));
	 	memset(delta,0,sizeof(delta));
	 	memset(hy,0,sizeof(hy));
	 	memset(ly,0,sizeof(ly));
	 	for(i=1;i<=n;++i)
	 	 {
	 	 	scanf("%lld%lld%lld",&x,&y,&v);
	 	    ++tot; a[tot].x=x; a[tot].val=v; hy[tot]=y;
	 	    ++tot; a[tot].x=x+xx-1; a[tot].val=-v; hy[tot]=y+yy-1;
		  }
		for(i=1;i<=tot;++i) num[i]=i;
		sort(num+1,num+tot+1,tmp);
		for(i=1;i<=tot;++i)
		 if(hy[num[i]]!=hy[num[i-1]]) ly[num[i]]=++cnt;
		  else ly[num[i]]=cnt;
		tot=0; tp=0;
		for(i=1;i<=n;++i) a[++tot].l=ly[++tp],a[tot].r=ly[++tp],a[++tot].l=a[tot-1].l,a[tot].r=a[tot-1].r;
		sort(a+1,a+tot+1,cmp);
		for(i=1;i<=tot;++i)
		 {
		 	change(1,1,cnt,a[i].l,a[i].r,a[i].val);
		 	ll ss=ask(1,1,cnt,1,cnt);
		 	if(ss>ans) ans=ss;
		  } 
		printf("%lld\n",ans);
	 }
}</strong></span>

 

转载于:https://www.cnblogs.com/lris-searching/p/9403108.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值