poj 2482 Stars in Your Window(扫描线+区间最值)

Stars in Your Window
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7013 Accepted: 1871

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

Source,

POJ Contest,Author:kinfkong@ZSU

题目:http://poj.org/problem?id=2482

题意:关于图片之前的故事,怎么说呢,跟我的经历有点像啊,果断收藏了,哈哈,然后又用的就在图片下面了,给你一些星星,星星在一个大平面上,然后给你个矩形的窗口,你要使得窗口里的星星总亮度最亮

分析:很容易想到离散化,然后就是线段树,至于怎么求和,还要最大值,其实只要假设本来就是长度小于边长里的亮度和,然后去最大,那么如果增加一颗星星,只会影响到它本身及其之后的小于边长的所以点。。。好吧,描述得很迷糊,看看代码吧,这题一开始有点写错了,然后就是出来覆盖那边出现了死循环不断的re。。。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define ls rt<<1
#define rs rt<<1|1
#define lson l,m,ls
#define rson m+1,r,rs
using namespace std;
const int mm=11111;
const int mn=mm<<2;
struct star
{
    int x,y,c;
}g[mm];
int dly[mn],sum[mn];
int y[mm],m;
void pushdown(int rt)
{
    sum[ls]+=dly[rt];
    sum[rs]+=dly[rt];
    dly[ls]+=dly[rt];
    dly[rs]+=dly[rt];
    dly[rt]=0;
}
void pushup(int rt)
{
    sum[rt]=max(sum[ls],sum[rs]);
}
void build()
{
    memset(dly,0,sizeof(dly));
    memset(sum,0,sizeof(sum));
}
void updata(int L,long long R,int val,int l,int r,int rt)
{
    if(L<=y[l]&&R>=y[r])
    {
        sum[rt]+=val;
        dly[rt]+=val;
        return;
    }
    if(dly[rt])pushdown(rt);
    int m=(l+r)>>1;
    if(L<=y[m])updata(L,R,val,lson);
    if(R>=y[m+1])updata(L,R,val,rson);
    pushup(rt);
}
bool cmp(star a,star b)
{
    return a.x<b.x;
}
int main()
{
    int i,j,k,n,w,h,ans;
    while(~scanf("%d%d%d",&n,&w,&h))
    {
        for(i=0;i<n;++i)
        {
            scanf("%d%d%d",&g[i].x,&g[i].y,&g[i].c);
            y[i]=g[i].y;
        }
        sort(y,y+n);
        for(m=i=0;i<n;++i)
            if(y[m]!=y[i])y[++m]=y[i];
        sort(g,g+n,cmp);
        build();
        ans=0;
        for(j=i=0;i<n;++i)
        {
            updata(g[i].y,(long long)g[i].y+h-1,g[i].c,0,m,1);
            while(j<=i&&g[i].x-g[j].x+1>w)
            {
                updata(g[j].y,(long long)g[j].y+h-1,-g[j].c,0,m,1);
                ++j;
            }
            ans=max(ans,sum[1]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值