Codeforces-233A Perfect Permutation

Perfect Permutation
Problem Description

A permutation is a sequence of integersp1,p2,...,pn, consisting ofn distinct positive integers, each of them doesn't exceedn. Let's denote the i-th element of permutation p aspi. We'll call numbern the size of permutation p1,p2,...,pn.

Nickolas adores permutations. He likes some permutations more than the others. He calls such permutations perfect. Aperfect permutation is such permutation p that for any i (1≤in) (n is the permutation size) the following equations holdppi=i andpii. Nickolas asks you to print any perfect permutation of sizen for the given n.

 

Input

A single line contains a single integer n (1≤n≤100) the permutation size.

 

Output

If a perfect permutation of size n doesn't exist, print a single integer -1. Otherwise print n distinct integers from 1 to n,p1,p2,...,pn permutationp, that is perfect. Separate printed numbers by whitespaces.

 

Sample Input
1
 
   
2
 

Sample Output
-1
 
   
2 1
 题目意思:
给你一个n,则会有排列p1,p2,p3,p4...pn,并且pi<=n,;
如果n的某个排列满足: ppi=i and pii.(1<=i<=n),则此排列为完美排列。
输出这个排列。。

可以找出规律,当n%2== 1 时,必定找不出符合条件的完美排列。。
所以有:
#include"stdio.h"
int main()
{
	int n; 
    while(scanf("%d", &n) != EOF) 
    { 
        if(n % 2) 
        { 
            printf("-1\n"); 
        } 
        else 
        { 
            int i; 
            for(i = 1; i <= n; i++) 
            { 
                if(i % 2) 
                { 
                    printf("%d", i + 1); 
                } 
                else 
                    printf("%d", i - 1); 
                if(i != n) 
                    printf(" "); 
            } 
            printf("\n"); 
        } 
	}
	return 0;
}



转载于:https://www.cnblogs.com/yyf573462811/archive/2012/11/15/6365153.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值