usaco 1.3.2 (barn1)

题意:

Barn Repair

It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:M, S, and C (space separated)
Lines 2-C+1:Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.] 

 

题意就是说有一排牛棚,对于里面有牛的牛棚要用板子拦着,最多提供M个板子(每个板子长度不限),接下来是c个有牛的牛棚编号,问最短要买多长的板子

题目放在了贪心里面,所以应该是用贪心,但是这个我没想到怎么贪,相反,模拟的过程很容易,就是对于距离很大的两个牛棚,我们尽量不用一块板子(显然空的部分浪费大啊),就直接找出距离最大的M-1个空,把他们隔开就行了(第一遍写时没注意,直接隔了M个,所以错了),后来改了但是它输入的c个数是无序的,我默认有序了有WA了一次

代码:

/*
ID:614433244
PROG: barn1
LANG: C++
*/
#include"iostream"
#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
struct M
{
    int v,p;
}b[201];
bool cmp( M a,M b )
{
    return a.v>b.v;
}
int main()
{
    freopen("barn1.in","r",stdin);
    freopen("barn1.out","w",stdout);
    int m,s,c;
    int a[201];
    bool map[201];
    memset(map,0,sizeof(map));
    int i;
    scanf("%d%d%d",&m,&s,&c);
    for( i=1;i<=c;i++ )
        scanf("%d",&a[i]);
    sort(&a[1],&a[c+1]);
    for( i=1;i<c;i++ )
    {
        b[i].v=a[i+1]-a[i];
        b[i].p=i;
    }
    sort( &b[1],&b[c],cmp );
    for( i=1;i<m;i++ )
        map[ b[i].p ]=1;
    map[c]=1;
    int t=1;
    int sum=0;
    for( i=1;i<=c;i++ )
    {
        if( map[i]==1 )
        {
            sum+=a[i]-a[t]+1;
            t=i+1;
        }
    }
    printf("%d\n",sum);
    return 0;
}

 

 

转载于:https://www.cnblogs.com/rolyxiao/archive/2012/06/08/2542007.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值