Another Eight Puzzle

Problem Description

Fill the following 8 circles with digits 1~8,with each number exactly once . Conntcted circles cannot be filled with two consecutive numbers. 
There are 17 pairs of connected cicles: 
A-B , A-C, A-D 
B-C, B-E, B-F 
C-D, C-E, C-F, C-G 
D-F, D-G 
E-F, E-H 
F-G, F-H 
G-H 

 

Filling G with 1 and D with 2 (or G with 2 and D with 1) is illegal since G and D are connected and 1 and 2 are consecutive .However ,filling A with 8 and B with 1 is legal since 8 and 1 are not consecutive . 
In this problems,some circles are already filled,your tast is to fill the remaining circles to obtain a solution (if possivle). 
Input 
The first line contains a single integer T(1≤T≤10),the number of test cases. Each test case is a single line containing 8 integers 0~8,the numbers in circle A~H.0 indicates an empty circle. 
Output 
For each test case ,print the case number and the solution in the same format as the input . if there is no solution ,print “No answer”.If there more than one solution,print “Not unique”. 
Sample Input 

7 3 1 4 5 8 0 0 
7 0 0 0 0 0 0 0 
1 0 0 0 0 0 0 0 
Sample Output 
Case 1: 7 3 1 4 5 8 6 2 
Case 2: Not unique 

Case 3: No answer

 

题意:输入8个数 表示 图中a b c d e f g h的位置的值只能为1-8的数 然后相邻的不能是连续的数,即绝对值不能为1,有些数是0,将为0的填成1-8中未使用的数。

解题的关键在于判断是否是连续的数字,每次都从A开始找,找到最后,这样因为A和B搜索过,B就不需要再搜索A。

 

具体代码:

#include <iostream>
#include <string.h>
using namespace std;
int a[9],b[9];
bool isun,isan,vis[9];

// 自己做一个 求绝对值的函数= =。
int abs(int a)
{
  return a<0?-a:a;
}

bool je(int x,int y)
{
  // 如果两者任意一个是0 要按正确处理,让下一次判断来筛掉
  if(!a[x] || !a[y]) return false;
  if(abs(a[x]-a[y])==1) return true;
    return false;
}

  // 判断每个位置是否满足题意
  bool judge(int wz)
  {
    bool is;
    int i;
    for(i=1;i<=wz;++i)
    {
      switch(i)
      {
        case 1:
        {
          if(!je(1,2) && !je(1,3) && !je(1,4)) is=1;
          else is=0;
        };break;
        case 2:
        {
          if(!je(2,3) && !je(2,5) && !je(2,6)) is=1;
          else is=0;
        };break;
        case 3:
        {
          if(!je(3,4) && !je(3,5) && !je(3,6) && !je(3,7)) is=1;
          else is=0;
        };break;
        case 4:
        {
          if(!je(4,6) && !je(4,7)) is=1;
          else is=0;
        };break;
        case 5:
        {
          if(!je(5,6) && !je(5,8)) is=1;
          else is=0;
        };break;
        case 6:
        {
          if(!je(6,7) && !je(6,8)) is=1;
          else is=0;
        };break;
        case 7:
        {
          if(!je(7,8)) is=1;
          else is=0;
        };break;
        default:break;
      }
      if(!is) return false;
    }
    if(!is) return false;
      return true;
  }

void dfs(int n)
{
  int i;
  if(isun) return;
  if(n==9 && isan==1){isun=1;return;}
  if(n==9)
  {
  // 将正确的数存起来
    for(int j=1;j<=8;++j)
      b[j]=a[j];
    isan=1;
    return;
  }

  if(a[n]!=0) dfs(n+1);
  else
  {
    for(i=1;i<=8;++i)
    {
      if(vis[i]==0 && judge(n))
      {
        vis[i]=1;
        a[n]=i;
        dfs(n+1);
        // 不止vis数组恢复为0,a[n]也要恢复
        a[n]=0;
        vis[i]=0;
      }
    }
  }
}

int main()
{
  int total,i;
  cin>>total;
  for(int num=1;num<=total;++num)
  {
    memset(vis,0,sizeof(vis));
    for(i=1;i<=8;++i)
    {
      cin>>a[i];
      if(a[i]!=0) vis[a[i]]=1;
    }

  // isun表示是否有多个答案 isan表示是否有答案
    isun=0;
    isan=0;
    dfs(1);

    cout<<"Case "<<num<<":";

    if(isan==0 && isun==0) cout<<" No answer"<<endl;
    else if(isun==1 && isan==1) cout<<" Not unique"<<endl;
    else if(isun==0 && isan==1)
    {
      for(i=1;i<=8;++i)
      cout<<" "<<b[i];
      cout<<endl;
    }
  }
  return 0;
}

转载于:https://www.cnblogs.com/2016zhanggang/p/5428377.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
单词搜索迷宫(Word Search Puzzle)问题是一个经典的算法问题,其输入是一个二维的字符数组和一组单词,目标是找出字符数组网格中的所有单词。这些单词可以是水平的、垂直的或者是任意的对角线方向,所以需要查找8个不同的方向。解决这个问题的一种常见方法是使用回溯算法,具体步骤如下: 1. 遍历二维字符数组,对于每个字符,以其为起点开始搜索,搜索的方向包括水平、垂直和对角线方向。 2. 对于每个搜索到的单词,将其记录下来。 3. 重复步骤1和2,直到遍历完整个二维字符数组。 下面是一个使用C#语言实现的单词搜索迷宫算法的示例代码: ```csharp class WordSearchPuzzle { private char[,] grid; private HashSet<string> words; public WordSearchPuzzle(char[,] grid, HashSet<string> words) { this.grid = grid; this.words = words; } public void Solve() { int rows = grid.GetLength(0); int cols = grid.GetLength(1); for (int i = 0; i < rows; i++) { for (int j = 0; j < cols; j++) { Search(i, j, new StringBuilder()); } } } private void Search(int row, int col, StringBuilder sb) { if (row < 0 || row >= grid.GetLength(0) || col < 0 || col >= grid.GetLength(1)) { return; } sb.Append(grid[row, col]); string word = sb.ToString(); if (words.Contains(word)) { Console.WriteLine("Found '{0}' at [{1}, {2}] to [{3}, {4}]", word, row, col, row - sb.Length + 1, col - sb.Length + 1); } if (word.Length < 3) { Search(row + 1, col, sb); Search(row - 1, col, sb); Search(row, col + 1, sb); Search(row, col - 1, sb); Search(row + 1, col + 1, sb); Search(row - 1, col - 1, sb); Search(row + 1, col - 1, sb); Search(row - 1, col + 1, sb); } sb.Remove(sb.Length - 1, 1); } } // 使用示例 char[,] grid = new char[,] { {'t', 'h', 'i', 's'}, {'w', 'a', 't', 's'}, {'o', 'a', 'h', 'g'}, {'f', 'g', 'd', 't'} }; HashSet<string> words = new HashSet<string>() { "this", "two", "fat", "that" }; WordSearchPuzzle puzzle = new WordSearchPuzzle(grid, words); puzzle.Solve(); ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值