hdu 2514 Another Eight Puzzle

以前大都是看了大神的思路代码,今天纯原创,好高兴,记录下

Another Eight Puzzle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 597 Accepted Submission(s): 361


Problem Description
Fill the following 8 circles with digits 1~8,with each number exactly once . Conntcted circles cannot be filled with two consecutive numbers.
There are 17 pairs of connected cicles:
A-B , A-C, A-D
B-C, B-E, B-F
C-D, C-E, C-F, C-G
D-F, D-G
E-F, E-H
F-G, F-H
G-H

Filling G with 1 and D with 2 (or G with 2 and D with 1) is illegal since G and D are connected and 1 and 2 are consecutive .However ,filling A with 8 and B with 1 is legal since 8 and 1 are not consecutive .

In this problems,some circles are already filled,your tast is to fill the remaining circles to obtain a solution (if possivle).


 

Input
The first line contains a single integer T(1≤T≤10),the number of test cases. Each test case is a single line containing 8 integers 0~8,the numbers in circle A~H.0 indicates an empty circle.


 

Output
For each test case ,print the case number and the solution in the same format as the input . if there is no solution ,print “No answer”.If there more than one solution,print “Not unique”.


 

Sample Input
  
  
3 7 3 1 4 5 8 0 0 7 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0


 

Sample Output
  
  
Case 1: 7 3 1 4 5 8 6 2 Case 2: Not unique Case 3: No answer


 

Source


 

Recommend
lcy

 

#include<stdio.h>
 #include<mem.h>
 using namespace std;
 int map[9];
 int vis[9];
 int ans[9];
 int x[9][9]=
 {
     {9,9,9,9,9,9,9,9,9},
     {9,9,2,3,4,9,9,9,9},
     {9,1,9,3,9,5,6,9,9},
     {9,1,2,9,4,5,6,7,9},
     {9,1,9,3,9,9,6,7,9},
     {9,9,2,3,9,9,6,9,8},
     {9,9,2,3,4,5,9,7,8},
     {9,9,9,3,4,9,6,9,8},
     {9,9,9,9,9,5,6,7,9}
 };
 int num=0;
 void DFS(int i)
 {
     int j;
     int p;
     if(i==9)
     {
         num++;
         for(int pp=1; pp<=8; pp++)
         {
             ans[pp]=map[pp];
         }
         return;
     }
     if(map[i]==0)
     {
         for(j=1; j<=8; j++)
         {
             if(vis[j]==true)
             {
                 continue;
             }
             for(p=1; p<=8; p++)
             {
                 if( x[i][p]!=9 )
                 {
                     if((j==map[ x[i][p] ]+1||j==map[ x[i][p] ]-1)&&(map[ x[i][p] ]!=0) )
                     {
                         break;
                     }
                 }
                 if(p==8)
                 {
                     map[i]=j;
                     vis[j]=true;
                     DFS(i+1);
                     map[i]=0;
                     vis[j]=false;
                 }
             }
         }
     }
     else
     {
         DFS(i+1);
     }
 }
 int main()
 {
     int i,k,t;
     scanf("%d",&t);
     for(k=1; k<=t; k++)
     {
         memset(vis,false,sizeof(vis));
         num=0;
         for(i=1; i<=8; i++)
         {
             scanf("%d",&map[i]);
             vis[map[i]]=true;
         }
         DFS(1);
         printf("Case %d:",k);
         if(num==0)
         {
             printf(" No answer\n");
         }
         else if(num>=2)
         {
             printf(" Not unique\n");
         }
         else
         {
             for(i=1; i<=8; i++)
             {
                 printf(" %d",ans[i]);
             }
             printf("\n");
         }
     }
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值