POJ 2184 Cow Exhabition

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 
 
显然是个0/1背包 把 s 当做体积,f 当做重量就可以。
 但是问题在于物品的体积有负数。
一般情况下,我们做的背包都是体积在一个以 0 为左端点的区间。
这道题变成了 一个 -1000*100 到 1000*100 的区间,我们可以将这个区间整体向右平移 100000
这样的话 原点移动到了 100000 这个点。左端点从 -1000*100 变成了 0
然后再分类讨论 s 的正负,进而决定是从大到小还是从小到大dp
 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int inf = 1<<30;
const int dir = 100000;
int dp[200005];
struct s{
    int s, f;
}arr[105];

int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d%d",&arr[i].s,&arr[i].f);
    
    for(int i=0;i<=200000;i++)
        dp[i] = -inf;
    dp[100000] = 0;
    
    for(int i=0;i<n;i++){
        if(arr[i].s < 0 && arr[i].f < 0)
            continue;
        if(arr[i].s>0){
            for(int j=200000;j>=arr[i].s;j--){
                if(dp[j-arr[i].s] > -inf){
                    dp[j] = max(dp[j],dp[j-arr[i].s]+arr[i].f);
                }
            }

        }else {// arr[i].s < 0  arr[i].f>=0
            for(int j=arr[i].s;j<=200000+arr[i].s;j++){
                if(dp[j-arr[i].s] > -inf){
                    dp[j] = max(dp[j],dp[j-arr[i].s]+arr[i].f);
                }
            }
        }
    }
    int ans = 0;
    for(int i=100000;i<=200000;i++){
        if(dp[i]>=0)
            ans = max(ans, dp[i]+i-100000);
    }
    printf("%d\n",ans);
    return 0;
}
View Code

 

对代码进行了优化。

首先是将dp从数组名变成了指针,令dp指向buf[100000]

这样、数组下标为负数时也不会越界。

优化关键在设置了两个变量,分别记录了有效区间的两个端点。

比如说 在处理第一个数的时候整个区间的都是无法达到的(除了原点)

而再像优化前的代码一样遍历一个200000的区间是无用的冗余。

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int inf = 1<<30;
int buf[200005];
int *const dp = buf + 100000;

int main(){
    int n, s, f;
    scanf("%d",&n);

    for(int i=0;i<=200000;i++)
        buf[i] = -inf;
    dp[0] = 0;// dp[0] == buf[100000]

    int l = 0, r = 0;// 有效区间的左端点和右端点
    for(int i=0;i<n;i++){
        scanf("%d%d",&s,&f);
        if(s<0 && f <0)//舍弃无用点
            continue;
        if(s > 0){// 体积为正数 所以从大到小dp
            for(int i=r;i>=l;i--)
                dp[i+s] = max(dp[i+s],dp[i]+f);
        }else {
            for(int i=l;i<=r;i++)
                dp[i+s] = max(dp[i+s],dp[i]+f);
        }
        if(s>0)
            r += s;
        else
            l += s;
    }
    int ans = 0;
    for(int i=0;i<=r;i++){
        if(dp[i] >= 0)
            ans = max(ans, dp[i]+i);
    }
    printf("%d\n",ans);
    return 0;
}
View Code

 

 

转载于:https://www.cnblogs.com/kongbb/p/10452901.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值