usaco 1.2.5dualpal

题目:

Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)

and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28

题目意思很简单,就是求出比S大的,在两种不同进制下是回文数的 n 个数,,输出来就行了,题目归在了1.2中,显然是暴力了,而且数据范围又都不大,暴力自然是可以过的,更上一题一样写个进制转换函数,判断回文数函数就行了。
/*
ID:614433244
PROG: dualpal
LANG: C++
*/
#include"iostream"
#include"cstdio"
int a[32],bet;
void f( int m,int n )//m转换成n进制,并存在数组a里
{
    bet=0;
    while( m )
    {
        a[bet]=m%n;
        m=m/n;
        bet++;
    }
}
bool isback()//判断a是否回文
{
    int i,j;
    bool flag=true;
    for( i=0,j=bet-1; i<j; i++,j-- )
    {
        if( a[i]!=a[j] )
        {
            flag=false;
            break;
        }
    }
    return flag;
}
int main()
{
    freopen("dualpal.in","r",stdin);
    freopen("dualpal.out","w",stdout);
    int n,s;
    scanf("%d%d",&n,&s);
    int i,j;
    for( i=s+1;n>0;i++ )
    {
        int temp=0;
        for( j=2;j<=10;j++ )
        {
            f( i,j );
            if( isback() )
                temp++;
            if( temp==2 )
                break;
        }
        if( temp==2 )
        {
            printf("%d\n",i);
            n--;
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/rolyxiao/archive/2012/06/03/2533042.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值