SDUT——OJ 1500 Message Flood

Message Flood

 
Time Limit: 1500ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3

来源

第9届中山大学程序设计竞赛预选赛
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    int flag;
    struct node *next[26];
}*A,M;
A creat()
{
    int i;
    A p = (A)malloc(sizeof(M));
    for( i = 0; i < 26; i++)
    {
        p -> next[i] = NULL;
    }
    p -> flag = 0;
    return p;
}
int find (A p , char  s[])
{
    int i,t;
    int len=strlen(s);
    for( i = 0;i<len;i++)
    {
        if(s[i] >= 'A' && s[i] <= 'Z')
            t=s[i]-'A';
            else
                t=s[i]-'a';
        if(p -> next[t] == NULL)
        {
            return 0;
        }
        p = p -> next[t];
    }
    if(p -> flag)
    {
        p -> flag =0;
        return 1;
    }
    return 0;
}

void inset(A p,char s[])
{
    int i,t;
    int len=strlen(s);
    for(i=0;i<len;i++)
    {
        if(s[i]>='A'&&s[i]<='Z')
            t=s[i]-'A';
        else
            t=s[i]-'a';
        if(p -> next[t] == NULL)
        {
            p -> next[t] = creat();
        }
        p = p -> next[t];
    }
    p -> flag = 1;
}
void free1(A p)
{
    int i;
    if(p == NULL)
        return;
    for(i = 0;i < 26; i++)
    {
        free1(p -> next[i]);
    }
    free(p);
    return;
}
int main()
{
    int n,m,sum,i,t;
    char s[100],name[20002][15];
    A tree;
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        sum=0;
        tree = creat();
        for(i=0;i<n;i++)
            scanf("%s",name[i]);
        while(m--)
        {
            scanf("%s",s);
            inset(tree,s);
        }
        for(i=0;i<n;i++)
            sum+=find(tree,name[i]);
        free1(tree);
        printf("%d\n",n-sum);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Misty5/articles/4050898.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值