巨大的斐波那契数列

The i’th Fibonacci number f(i) is recursively defined in the following way: • f(0) = 0 and f(1) = 1 • f(i + 2) = f(i + 1) + f(i) for every i ≥ 0 Your task is to compute some values of this sequence.
Input Input begins with an integer t ≤ 10,000, the number of test cases. Each test case consists of three integers a, b, n where 0 ≤ a,b < 264 (a and b will not both be zero) and 1 ≤ n ≤ 1000.
Output
For each test case, output a single line containing the remainder of f(ab) upon division by n.
Sample Input
3 1 1 2 2 3 1000 18446744073709551615 18446744073709551615 1000
Sample Output
1 21 250

 

 

 

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
typedef unsigned long long ll;
using namespace std;
const int maxn=1000+10;

ll a,b;
int f[maxn*maxn],n,M;

int pow(ll a,ll p,int Mod)
{
    int ret=1;
    while(p)
    {
        if(p & 1)ret*=a,ret%=Mod;
        a*=a;a%=Mod;
        p>>=1;
    }
    return ret;
}

inline void solve()
{
    cin>>a>>b>>n;
    if(n==1||!a){printf("0\n");return ;}
    f[1]=1,f[2]=1;
    for(int i=3;i<=n*n+10;i++)
    {
        f[i]=f[i-1]+f[i-2];f[i]%=n;
        if(f[i]==f[2]&&f[i-1]==f[1]) {M=i-2;break;}
    }
    int k=pow(a%M,b,M);
    printf("%d\n",f[k]);
}

int main()
{
    int T;cin>>T;
    while(T--) solve();
    return 0;
}

 

转载于:https://www.cnblogs.com/ylrwj/p/10786272.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值