1107 Social Clusters (30)(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K~i~: h~i~[1] h~i~[2] ... h~i~[K~i~]

where K~i~ (>0) is the number of hobbies, and h~i~[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
题意很明显,求有某些相同爱好的人的集合的人数。
并查集,凡是有相同的爱好的人都归到一个集合里,最后查一下每一个集合里的人数,存下来,降序排序输出。
代码:
#include <stdio.h>
#include <stdlib.h>
int n,m,d,c,f[1001],mp[1001][1001],num[1001],ans[1001];
void init() {
    for(int i = 1;i <= n;i ++) {
        f[i] = i;
    }
}
int getf(int x) {
    if(x != f[x])f[x] = getf(f[x]);
    return f[x];
}
void mer_(int x,int y) {
    int xx = getf(x),yy = getf(y);
    f[xx] = yy;
}
int cmp(const void *a,const void *b) {
    return *(int *)b - *(int *)a;
}
int main() {
    scanf("%d",&n);
    init();
    for(int i = 1;i <= n;i ++) {
        scanf("%d:",&m);
        for(int j = 1;j <= m;j ++) {
            scanf("%d",&d);
            mp[i][d] = 1;
            for(int k = 1;k < i;k ++) {
                if(mp[k][d])mer_(k,i);
            }
        }
    }
    for(int i = 1;i <= n;i ++) {
        int e = getf(i);
        num[e] ++;
    }
    for(int i = 1;i <= n;i ++) {
        if(num[i])ans[c ++] = num[i];
    }
    qsort(ans,c,sizeof(int),cmp);
    printf("%d\n",c);
    for(int i = 0;i < c;i ++) {
        if(i)putchar(' ');
        printf("%d",ans[i]);
    }
}

 

转载于:https://www.cnblogs.com/8023spz/p/9279804.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
非常抱歉,我的回答里有误,`clusters.erase`应该改为`clusters.erase(clusters.begin() + minCluster2)`。这是因为 `clusters` 是一个 `vector`,我们需要使用 `vector` 的 `erase` 函数来删除其中的元素。 完整的代码如下: ```c++ #include <iostream> #include <vector> #include <cmath> #include <limits> using namespace std; struct DataPoint { double value; int cluster; }; double getDistance(const DataPoint& p1, const DataPoint& p2) { return fabs(p1.value - p2.value); } void mergeClusters(vector<DataPoint>& data, int cluster1, int cluster2) { for (auto& point : data) { if (point.cluster == cluster2) { point.cluster = cluster1; } } } void hierarchicalClustering(vector<DataPoint>& data) { int n = data.size(); vector<int> clusters(n); for (int i = 0; i < n; ++i) { clusters[i] = i; } while (n > 1) { double minDist = numeric_limits<double>::max(); int minCluster1 = -1, minCluster2 = -1; for (int i = 0; i < n-1; ++i) { for (int j = i+1; j < n; ++j) { double dist = getDistance(data[i], data[j]); if (dist < minDist) { minDist = dist; minCluster1 = clusters[i]; minCluster2 = clusters[j]; } } } mergeClusters(data, minCluster1, minCluster2); clusters.erase(clusters.begin() + minCluster2); for (auto& point : data) { if (point.cluster > minCluster2) { --point.cluster; } } --n; } } int main() { vector<DataPoint> data = {{1.0, 0}, {2.0, 1}, {5.0, 2}, {6.0, 3}, {7.0, 4}, {8.0, 5}}; hierarchicalClustering(data); for (const auto& point : data) { cout << point.value << " " << point.cluster << endl; } return 0; } ``` 该程序可以将输入的数据按照差值进行聚类,并输出每个数据点所属的簇的编号。输入的数据是一个包含六个数据点的向量,每个数据点包含数据本身和所属的簇的编号。在程序中,我们首先对每个数据点初始化一个簇的编号,然后进行层次聚类,最终得到每个数据点所属的最终簇的编号。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值