1107 Social Clusters (30分)

问题

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] … h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

解决方法

题目大意

这道题意思是给出每个人的爱好,然后根据喜好形成不同的社交圈子,最后输出圈子的个数以及每个圈子多少人(降序排列)。

解决方法

并查集问题
♦先写出模板,findfather,union,init函数。
♦根据输入的顺序,如果hobby[t]=0,那说明hobby没有出现过,hobby的所有者是i(人的序号)。如果出现过,那么就和hobby[t]的祖宗合并。这样就建立了一个社交图。
♦最后遍历,找出祖宗,降序输出。

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1010;
int hobby[maxn], father[maxn], root[maxn];
int findfather(int root)
{
	int son = root;
	while (root != father[root]) root = father[root];
	while (son != father[son])
	{
		int tmp = son;
		son = father[son];
		father[tmp] = root;
	}
	return root;
}
void Union(int a,int b)
{
	int faa = findfather(a);
	int fab = findfather(b);
	if (faa != fab) father[faa] = fab;
}
void init()
{
	for (int i = 0; i < maxn; i++)
	{
		father[i] = i;
		root[i] = 0;
		hobby[i] = 0;
	}
}
int main()
{
	init();
	int n, k, t, cnt = 0;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d:", &k);
		for (int j = 0; j < k; j++)
		{
			scanf("%d", &t);
			if (hobby[t] == 0) hobby[t] = i;
			Union(i, findfather(hobby[t]));
		}
	}
	for (int i = 1; i <= n; i++) root[findfather(i)]++;
	for (int i = 0; i < maxn; i++)
	{
		if (root[i]) cnt++;
	}
	sort(root, root + maxn, greater<int>());
	printf("%d\n", cnt);
	for (int i = 0; i < cnt; i++)
	{
		if (i != 0) printf(" ");
		printf("%d", root[i]);
	}
	return 0;
}

后记

最后降序输出的时候,把greater和less的顺序记反了。。。greater是降序,less是升序。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值