T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.
Input
On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.
Output
For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.
Sample Input
2
1
124866
3
124866
111111
987651
Sample Output
1
8
解题思路:
只要所有数除以答案的余数不同就可以了。从1开始往上挨个试,只到找到答案。应该用for(j=1; ;j++),不用限制j的上限,找到答案直接break就可以了。
#include<stdio.h>
#include<memory.h>
int used[1000001];
//不要一直用memset(used,0,sizeof(used))可以直接j*sizeof(int)
//不要限制j上限
int main()
{
int n,g,i,j,stu[301],mod,flag,k;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&g);
for(j=1;j<=g;j++)
{
scanf("%d",&stu[j]);
}
for(j=1;;j++)
{
memset(used,0,j*sizeof(int));
flag=1;
for(k=1;k<=g;k++)
{
mod=stu[k]%j;
if(used[mod]==0)
{
used[mod]=1;
}
else
{
flag=0;
break;
}
}
if(flag==1)
{
printf("%d\n",j);
break;
}
else
{
continue;
}
}
}
}