7-5 银行业务队列简单模拟 (25 分)
设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。
输入格式:
输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。
输出格式:
按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。
输入样例:
8 2 1 3 9 4 11 13 15
输出样例:
1 3 2 9 11 4 13 15
#include<bits/stdc++.h>
#define OK 1
#define ERROR 0
#define OVERFLOW -2
using namespace std;
typedef long long ll;
struct LinkQueue{
int *base;
int front,last;
};
void InitQueue(LinkQueue& q){
q.base = (int*)malloc(1007*sizeof(int));
q.front = q.last = 0;
}
void push(LinkQueue&q,int e){
q.base[q.last++] = e;
}
void pop(LinkQueue&q){
q.front++;
}
int GetTop(LinkQueue&q){
return q.base[q.front];
}
int EmptyQueue(LinkQueue&q){
if(q.front==q.last) return true;
return false;
}
int main()
{
//freopen("i.txt","r",stdin);
int n;
LinkQueue q1,q2;
scanf("%d",&n);
InitQueue(q1);InitQueue(q2);
for(int i=1;i<=n;i++){
int e;
scanf("%d",&e);
if(e&1){
push(q1,e);
}else push(q2,e);
}
int i=0;
while(!EmptyQueue(q1)||!EmptyQueue(q2)){
if(!EmptyQueue(q1)){
if(i++) printf(" ");
cout<<GetTop(q1);
pop(q1);
}
if(!EmptyQueue(q1)){
if(i++) printf(" ");
cout<<GetTop(q1);
pop(q1);
}
if(!EmptyQueue(q2)){
if(i++) printf(" ");
cout<<GetTop(q2);
pop(q2);
}
}
}