1127. ZigZagging on a Tree (30)

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
题意:给定中序、后序,求出给二叉树的螺旋层序输出(ZigZagging )。

分析:中后序确认二叉树没什么好说的,如果有问题点击这里

           题目对层序输出做了一个变形,要求左右来回扫荡输出,开始的时候想着判断当前是第几行然后根据奇偶性从左往右输入or从右往左输入

           但是做的时候发现,新输入的会对原来的判定造成影响,然后左左右右的什么很麻烦

           后来想到,其实只需要按原来的层序遍历,加入两个计数器判断行数,然后按奇偶左右遍历就行了

代码:

#include<iostream>
#include<deque>
using namespace std;
struct node{
	int data;
	struct node *lchild,*rchild;
	node(){
		data=0;
		lchild=NULL;
		rchild=NULL;
	}
};
int pos[40]={0};
int mid[40]={0};
int index=0,n;
struct node * creat(int start,int end){
	index--;
	struct node *p = new struct node;
	int i;
	for(i=0;i<n;i++)
		if(mid[i]==pos[index]) break;	
	p->data=pos[index];
	if(i+1<end) p->rchild=creat(i+1,end);
	if(start<i) p->lchild=creat(start,i);
	return p;
}
void level_out(struct node root){
	deque<struct node> q;
	q.push_back(root);
	int times=0,cnt=1,now_cnt=0;
	cout<<root.data;
	while(q.size()){
		if(q.front().lchild) {	q.push_back(*q.front().lchild);	now_cnt++;}
		if(q.front().rchild) {	q.push_back(*q.front().rchild);	now_cnt++;} 
		q.pop_front();
		cnt--;
		if(cnt==0){
			times++;
			if(times%2) for(int i=0;i<q.size();i++) cout<<" "<<q.at(i).data;
			else for(int i=q.size()-1;i>=0;i--) cout<<" "<<q.at(i).data;
			cnt=now_cnt;
			now_cnt=0; 
		}
	}
}
int main()
{
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>mid[i];
	for(int i=0;i<n;i++)
		cin>>pos[i];
	index=n;
	struct node root;
	root=*creat(0,n);	
	level_out(root);
	return 0;
}


结尾:这应该是我第一道,一看就有思路,并且自己独立实现的30分题吧 _(:з」∠)_ 纪念一下


转载于:https://www.cnblogs.com/childwang/p/8280270.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值