1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

建树,然后双端队列层序遍历,奇数层和偶数层的进出队方向注意区分。

代码如下:


#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
#include<set>
#include<queue>
using namespace std;
int n;
int in[31], post[31];
struct Node {
	int val;
	int left = -1, right = -1;
}node[31];
int root;
int k = 1;
int lvln[31];
void buildtree(int root,int x) {
	if (x > root) {
		if (node[root].right == -1) {
			node[root].right = x;
			lvln[k]++;
		}
		else {
			k++;
			buildtree(node[root].right, x);
			k--;
		}
	}
	else {
		if (node[root].left == -1) {
			node[root].left = x;
			lvln[k]++;
		}
		else {
			k++;
			buildtree(node[root].left, x);
			k--;
		}
	}
}
vector<int> zzorder(int root) {
	deque<int> dq;
	dq.push_back(root);
	vector<int> v;
	int cnt = 0;
	while (!dq.empty()) {
		if (cnt % 2 == 1) {
			int top = dq.front();
			dq.pop_front();
			v.push_back(node[top].val);
			lvln[cnt]--;
			if (lvln[cnt] == 0) cnt++;
			if (node[top].left != -1) dq.push_back(node[top].left);
			if (node[top].right != -1) dq.push_back(node[top].right);
		}
		else {
			int top = dq.back();
			dq.pop_back();
			v.push_back(node[top].val);
			lvln[cnt]--;
			if (lvln[cnt] == 0) cnt++;
			if (node[top].right != -1) dq.push_front(node[top].right);
			if (node[top].left != -1) dq.push_front(node[top].left);
		}
	}
	return v;
}
int main() {
	cin >> n;
	for (int i = 0; i < n; i++) {
		scanf("%d", &in[i]);
		node[i].val = in[i];
	}
	for (int i = 0; i < n; i++) {
		scanf("%d", &post[i]);
	}
	for (int i = n - 1; i >= 0; i--) {
		for (int j = 0; j < n; j++) {
			if (i == n - 1 && in[j] == post[i]) {
				root = j;
				break;
			}
			else if (i != n - 1 && in[j] == post[i]) {
				buildtree(root, j);
				break;
			}
		}
	}
	vector<int> v;
	lvln[0] = 1;
	v = zzorder(root);
	printf("%d",v[0]);
	for (int i = 1; i < n; i++) {
		printf(" %d", v[i]);
	}
	printf("\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值