POJ3450 Corporate Identity 【后缀数组】

Corporate Identity
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 7662 Accepted: 2644

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

1A后缀数组真是快意【模板越敲越来劲】

这道题就是求多字符串的公共最长子串

之前已经写过一个类似的了

把所有字符串分别用一个其它的标识符作为分隔连接起来【分隔符互不相同以保证不参与匹配】

注意这里的字符串比较多,分隔符就有很多,所以不能用char存,要用int存

之后就是二分长度,看看height的每个分组中是否N个串都在里面

找到最大长度再跑一次找到第一个满足要求的分组输出

#include<iostream>
#include<cstdio>
#include<cctype>
#include<cstring>
#include<algorithm>
#define LL long long int
#define REP(i,n) for (int i = 1; i <= (n); i++)
#define REP0(i,n) for (int i = 0; i <= (n); i++)
#define PER(i,n) for (int i = (n); i >= 1; i--)
#define Redge(u) for (int k = head[u]; k != -1; k = edge[k].next)
using namespace std;
const int maxn = 1000005,maxm = 4005,INF = 1000000000;
int N,Min,r[maxn];
char A[maxn];
int sa[maxn],rank[maxn],height[maxn],t1[maxn],t2[maxn],c[maxn],id[maxn],vis[maxm],n,m;
void SA(){
	int *x = t1,*y = t2;
	REP0(i,m) c[i] = 0;
	REP(i,n) c[x[i] = r[i]]++;
	REP(i,m) c[i] += c[i - 1];
	PER(i,n) sa[c[x[i]]--] = i;
	for (int k = 1; k <= n; k <<= 1){
		int p = 0;
		for (int i = n - k + 1; i <= n; i++) y[++p] = i;
		REP(i,n) if (sa[i] - k > 0) y[++p] = sa[i] - k;
		REP0(i,m) c[i] = 0;
		REP(i,n) c[x[y[i]]]++;
		REP(i,m) c[i] += c[i - 1];
		PER(i,n) sa[c[x[y[i]]]--] = y[i];
		swap(x,y);
		x[sa[1]] = p = 1;
		for (int i = 2; i <= n; i++)
			x[sa[i]] = y[sa[i]] == y[sa[i - 1]] && y[sa[i] + k] == y[sa[i - 1] + k] ? p : ++p;
		if (p >= n) break;
		m = p;
	}
	REP(i,n) rank[sa[i]] = i;
	for (int i = 1,k = 0,j; i <= n; i++){
		if (k) k--;
		j = sa[rank[i] - 1];
		while (r[i + k] == r[j + k]) k++;
		height[rank[i]] = k;
	}
}
bool check(int K){
	memset(vis,-1,sizeof(vis));
	int cnt = 0,flag = 1;
	REP(i,n){
		if (id[sa[i]] == -1) {cnt = 0; ++flag; continue;}
		if (height[i] < K){
			cnt = 1; ++flag;
			vis[id[sa[i]]] = flag;
		}
		else {
			if (vis[id[sa[i]]] != flag) cnt++;
			vis[id[sa[i]]] = flag;
		}
		if (cnt == N) return true;
	}
	return false;
}
void print(int K){
	//cout<<"K:"<<K<<endl;
	memset(vis,-1,sizeof(vis));
	int cnt = 0,flag = 1,pos = 0;
	REP(i,n){
		if (id[sa[i]] == -1) {cnt = 0; ++flag; continue;}
		if (height[i] < K){
			cnt = 1; ++flag; pos = sa[i];
			vis[id[sa[i]]] = flag;
		}
		else {
			if (vis[id[sa[i]]] != flag) cnt++;
			vis[id[sa[i]]] = flag;
		}
		if (cnt == N){
			for (int i = 0; i < K; i++)
				putchar(r[pos + i]);
			puts("");
			return;
		}
	}
}
void solve(){
	int L = 0,R = Min,mid;
	while (L < R){
		mid = L + R + 1 >> 1;
		if (check(mid)) L = mid;
		else R = mid - 1;
	}
	if (!L) printf("IDENTITY LOST\n");
	else print(L);
}
int main(){
	while (~scanf("%d",&N) && N){
		m = 130; n = 0; Min = INF;
		REP(i,N){
			scanf("%s",A + 1);
			int len = strlen(A + 1); Min = min(Min,len);
			for (int j = 1; j <= len; j++) r[n + j] = A[j],id[n + j] = i;
			n += len; r[++n] = ++m; id[n] = -1;
		}
		//REP(i,n) printf("%c",isalpha(r[i]) ? r[i] : '#');cout<<endl;
		SA();
		//REP(i,n) cout<<sa[i]<<' ';cout<<endl;
		solve();
	}
	return 0;
}


转载于:https://www.cnblogs.com/Mychael/p/8282765.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值