ACM 第5题 Buildings

Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.

Input  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
Output  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
Sample Input

3
10 6
2 3
5 4
2
2 2
2 2
3
10 3
2 5
3 3

Sample Output

1
0
2



#include<stdio.h>
unsigned long long yizu(int n)
{
	unsigned long long w,s,max=0,sum=0;
	while(n--)
	{
		scanf("%llu%llu",&w,&s);
		if(w+s>max)          
		 max=w+s;
		 sum+=w;
	}
	sum-=max;
	return sum;	
	
}
int main()
{

  unsigned long long  n,sum1;
    while(scanf("%llu",&n)!=EOF)
    {
        sum1=yizu(n);
        printf("%llu\n",sum1);
    }
    return 0;
}

 

每层的 PDV等于这一层以上 重量之和(不包括本层)减去本层的s 。

所以可以知道 最下一层的PDV就是我们要求的 PDV 且我们要使这一层的PDV达到最小 就是我们的答案。

如样例的数据: 

3
10 6
2 3
5 4
2

则正确的摆放法式是
2 3
5 4
10 6
PDV = 2 + 5 - 6 = 1

w + s 越大越放在下面

对于相邻放置的两块板,设两块板为i,j他们上面的重量为sum。

1) PDV_a=sum-si;PDV_b=sum+wi-sj;

           交换两个板的位置      

  2)PDV_a'=sum+wj-si;PDV_b'=sum-sj;

          如果1优于2,求解得有效的条件为  wi-sj<wj-si 则移项得 wj+sj>si+si。

所以 PDV = sum-wj(去掉本层的重量)-sj

pdv[i]=sum(wi->wn)-wj-sj  所以提个负号 pdv=sum(wi -> wn)-(wj+sj)//使 wj+sj最大 PDV就会最小  

 


需要重点理解的地方,理解偏了就没法做了
1.PDV是最下层的不用理上层的PDV是多少。
2.PDV的计算不包括本层的重量。








转载于:https://www.cnblogs.com/ljzh/p/6340729.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值