(最小树形图 朱刘算法) poj 3164

Command Network
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 14340 Accepted: 4118

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<limits.h>
using namespace std;
const int MAXN = 110;
const int MAXM = 10010;

struct node
{
    int from;
    int to;
    double w;
};
node e[MAXM];

struct node1
{
    double x;
    double y;
};
node1 Point[MAXN];

double Dist(node1 a, node1 b)
{
    double x=a.x-b.x;
    double y=a.y-b.y;
    return sqrt(x*x+y*y);
}

int pre[MAXN],vis[MAXN],flag[MAXN];
double In[MAXN],sum;

double ZhuLiu(int root,int N,int M)
{
    sum=0;
    while(true)
    {
        for(int i=0;i<N;++i)
            In[i]=INT_MAX;
        for(int i=0;i<M;++i)
        {
            int u=e[i].from;
            int v=e[i].to;
            if(e[i].w<In[v]&&u!= v)
            {
                pre[v]=u;//v为终点,pre[v]存放起点
                In[v]=e[i].w;//权值最小的边
            }
        }

        for(int i=0;i<N;++i)//如果存在除root以外的孤立点,则不存在最小树形图
        {
            if(i==root)
                continue;
            if(In[i]==INT_MAX)
                return -1;
        }
        int CntNode=0;
        memset(flag,-1,sizeof(flag));
        memset(vis,-1,sizeof(vis));
        In[root]=0;
        for(int i=0;i<N;++i)   //找环,标记每个环
        {
            sum+=In[i];
            int v=i;
            while(vis[v]!=i&&flag[v]==-1&&v!=root)//每个点寻找其前序点,要么最终寻找至根部,要么找到一个环
            {
                vis[v]=i;
                v=pre[v];
            }
            if(v!=root&&flag[v]==-1)  //新图重新编号
            {
                for(int u=pre[v];u!=v;u=pre[u])
                    flag[u]=CntNode;
                flag[v]=CntNode++;
            }
        }
        if(CntNode==0)    //无环,跳出
            break;
        for(int i=0;i<N;++i)
        {
            if(flag[i]==-1)
                flag[i]=CntNode++;
        }
        for(int i=0;i<M;++i)  //建立新图,更新其他点到环的距离
        {
            int v=e[i].to;
            e[i].from=flag[e[i].from];
            e[i].to=flag[e[i].to];
            if(e[i].from!=e[i].to)
                e[i].w-=In[v];
        }
        N=CntNode;
        root=flag[root];
    }
    return sum;
}

int main()
{
    int x,y,N,M;
    while(~scanf("%d%d",&N,&M))
    {
        int id=0;
        for(int i=0;i< N;++i)
            scanf("%lf%lf",&Point[i].x,&Point[i].y);
        for(int i=0;i<M;++i)
        {
            scanf("%d%d",&x,&y);
            if(x==y)
                continue;
            x--;
            y--;
            e[id].from=x;
            e[id].to=y;
            e[id++].w=Dist(Point[x],Point[y]);
        }
        double ans=ZhuLiu(0,N,id);
        if(ans==-1)
            printf("poor snoopy\n");
        else
            printf("%.2f\n",ans);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/water-full/p/4485900.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值