HDU 3535 AreYouBusy (混合背包之分组背包)

题目链接

Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10

Sample Output
5
13
-1
-1

分析:
题目大意:有 n 组任务,T 个体力,每组任务有 m 个,分类为 type,每个任务花费 cose[] 体力,得到 value[] 的开心值,求最大开心值,若不能完成输出-1

     分类为 0:这一组中的 m 个任务至少选择一个。

     分类为 1:这一组中的 m 个任务最多选择一个。

     分类为 2:这一组中的 m 个任务随便选择。

定义:dp[i][k]:完成第 i 组任务时,体力为 k 时获得的开心值。
1.对于分类 0,若当前判断到一个任务 case,则有两种情况:

(1)它是该组第一个被选择的任务,则它更新的状态只能是将上一层的状态转移更新到当前位置。
dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+value[j]);

(2)它不是第一个被选择的任务,则它可以由当前组的状态转移更新到当前位置。
dp[i][k]=max(dp[i][k],dp[i][k-cost[j]]+value[j]);

为了方便判断处理第一个任务,初始化当前层为 -inf

2.对于分类 1,因为只能选一个或者不选,则它只能由上一层状态转移更新。
dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+value[j]);

3.对于分类 2,就是普通的 01背包问题
肯定是要从上层的转移过来:dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+value[j]);
但是还需要考虑到一点就是说,这个组里面的任务可以选取任意多的个数:
dp[i][k]=max(dp[i][k],dp[i][k-cost[j]]+value[j]);

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
const long long N=200;
using namespace std;
const int inf=0x3f3f3f3f;
int dp[N][N];
int n,T;
int cost[N],value[N];
int main()
{
    while(~scanf("%d%d",&n,&T))
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            int m,type;
            scanf("%d%d",&m,&type);
            for(int j=1; j<=m; j++)
                scanf("%d%d",&cost[j],&value[j]);
            if(type==0)//最少选择一个工作
            {
                for(int j=0; j<=T; j++) 
                    dp[i][j]=-inf;//方便处理第一个任务,初始化为-inf
                for(int j=1; j<=m; j++)
                    for(int k=T; k>=cost[j]; k--)
                    {
                        dp[i][k]=max(dp[i][k],dp[i][k-cost[j]]+value[j]);//不是改组中第一个任务,从改组中的其他任务更新来
                        dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+value[j]);//如果是改组中第一个被选择的任务,在从上一组更新来
                    }
            }
            else if(type==1)//选择一个或不选
            {
                for(int j=0; j<=T; j++) 
                    dp[i][j]=dp[i-1][j];//只能由上一层的状态转移来
                for(int j=1; j<=m; j++)
                    for(int k=T; k>=cost[j]; k--)
                    {
                        dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+value[j]);
                    }
            }
            else//可以任意的选择
            {
                for(int j=0; j<=T; j++) 
                    dp[i][j]=dp[i-1][j];//从上一层转移过来
                for(int j=1; j<=m; j++)
                    for(int k=T; k>=cost[j]; k--)
                    {
                        dp[i][k]=max(dp[i][k],dp[i][k-cost[j]]+value[j]);//由因为每组内的任务可以多选
                        dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+value[j]);//直接转移上一层的
                    }
            }
        }
        dp[n][T]=max(dp[n][T],-1);
        printf("%d\n",dp[n][T]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/cmmdc/p/7830759.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值